diff mbox series

[bug#41358] lm-sensors: pwmconfig is broken

Message ID 87a726hgpq.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#41358] lm-sensors: pwmconfig is broken | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Nicolò Balzarotti May 17, 2020, 12:46 p.m. UTC
Hello guix!

The current version of lm-sensors adjust grep path in the pwmconfig
script, replacing grep->/gnu/store/.../grep.  However, the script is
using egrep, leading to the non-existant e/gnu/store/.../grep path.
The attached patch fixes is actually replacing egrep->/gnu/store/../egrep

Thanks!

Comments

vasilii.smirnov--- via Guix-patches" via May 17, 2020, 3:12 p.m. UTC | #1
Nicolò,

Nicolò Balzarotti 写道:
> The current version of lm-sensors adjust grep path in the 
> pwmconfig
> script, replacing grep->/gnu/store/.../grep.  However, the 
> script is
> using egrep, leading to the non-existant e/gnu/store/.../grep 
> path.
> The attached patch fixes is actually replacing 
> egrep->/gnu/store/../egrep

Thanks!

As it was, this change would in turn break fancontrol which does 
use plain ‘grep’:

   INTERVAL=$(grep -E '^INTERVAL=.*$' $1 | …

I've modified it to match either and pushed as 
074cd595bbcd343f86aad09794d8781846ff1927.

Kind regards,

T G-R
Nicolò Balzarotti May 17, 2020, 3:19 p.m. UTC | #2
Hi Tobias!

Tobias Geerinckx-Rice via Guix-patches via <guix-patches@gnu.org>
writes:

> Nicolò,
>
> Nicolò Balzarotti 写道:
>> The current version of lm-sensors adjust grep path in the 
>> pwmconfig
>> script, replacing grep->/gnu/store/.../grep.  However, the 
>> script is
>> using egrep, leading to the non-existant e/gnu/store/.../grep 
>> path.
>> The attached patch fixes is actually replacing 
>> egrep->/gnu/store/../egrep
>
> Thanks!
>
> As it was, this change would in turn break fancontrol which does 
> use plain ‘grep’:
>
>    INTERVAL=$(grep -E '^INTERVAL=.*$' $1 | …
>
Sorry for missing that

> I've modified it to match either and pushed as 
> 074cd595bbcd343f86aad09794d8781846ff1927.
>
Thanks!
Nicolò

> Kind regards,
>
> T G-R
diff mbox series

Patch

From 1a0395630547868385312198659d5fda39845cbe Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Sun, 17 May 2020 14:39:17 +0200
Subject: [PATCH] gnu: lm-sensors: Use correct egrep path.

---
 gnu/packages/linux.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 290090456f..6dd4fdf747 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3541,9 +3541,9 @@  country-specific regulations for the wireless spectrum.")
                (("cat ")
                 (string-append (assoc-ref inputs "coreutils")
                                "/bin/cat "))
-               (("grep ")
+               (("egrep ")
                 (string-append (assoc-ref inputs "grep")
-                               "/bin/grep "))
+                               "/bin/egrep "))
                (("sed -e")
                 (string-append (assoc-ref inputs "sed")
                                "/bin/sed -e"))
-- 
2.26.2