diff mbox series

[bug#53535] gnu: Add emacs-popper

Message ID 87a6fafrku.fsf@posteo.net
State Accepted
Headers show
Series [bug#53535] gnu: Add emacs-popper | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Feb. 1, 2022, 5:02 p.m. UTC
Niklas Eklund <niklas.eklund@posteo.net> writes:

> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>
>> Hello,
>>
>> Niklas Eklund <niklas.eklund@posteo.net> writes:
>>
>>> this patch adds the emacs-popper package.
>>
>> Thank you. Somme comments follow..
>>
>>> Subject: [PATCH] gnu: Add emacs-popper.
>>
>> The commit message is missing a line:
>>
>>   * gnu/packages/emacs-xyz.scm (emacs-popper): New variable.

Aha, I hadn't grasped that before. Thanks for mentioning it. Fixed that
in this new patch.

>>> +(define-public emacs-popper
>>> +  ;; No tagged release upstream for version 0.45
>>
>> This is true, but the commit matching release 0.45 is
>> "851d83882192ac9599ac5b053614a42d683b3fab", not the one you're using.
>>
>>> +  (let ((commit "527a85c49174e6e79220f0ed0761c204a979eae6") (revision "0"))
>>
>> Could you add a newline between (commit ...) and (revision ...)?
>>> +    (package
>>> +      (name "emacs-popper")
>>> +      (version "0.45")
>>
>> You bound revision, but you're not actually making use of it. I think
>> there are two possibilities here:
>>
>> - if you use commit 851d83882192ac9599ac5b053614a42d683b3fab, you can
>>   keep using (version "0.45"), and explain in a comment that the chosen
>>   commit matches version bump;
>>
>> - if you use another commit, you need to use (git-version "0.45"
>>   revision commit) instead, and explain in a comment why you're using an
>>   untagged commit.
>>
>> Could you send an updated patch?

Good points. I have changed to the
851d83882192ac9599ac5b053614a42d683b3fab commit and dropped revision.

>> Regards,
>> -- 
>> Nicolas Goaziou

/Niklas

Comments

Nicolas Goaziou Feb. 7, 2022, 11:36 p.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:
> Subject: [PATCH] gnu: Add emacs-popper.

Applied. Thanks!

Regards,
diff mbox series

Patch

From 3f064617c9b001ced07a92bac86edcc7e31c2a1e Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Wed, 26 Jan 2022 00:23:29 +0100
Subject: [PATCH] gnu: Add emacs-popper.

* gnu/packages/emacs-xyz.scm (emacs-popper): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d9adbb1e5..865c7c4172 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7068,6 +7068,29 @@  (define-public emacs-popup
 and popup menus.")
     (license license:gpl3+)))
 
+(define-public emacs-popper
+  ;; No tagged release upstream for version 0.45
+  (let ((commit "851d83882192ac9599ac5b053614a42d683b3fab"))
+    (package
+      (name "emacs-popper")
+      (version "0.45")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/karthink/popper")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0pk5wzqlz7n6v8rb1957i3ql0wjx578l68a3rp2m9pxr7a8a03h4"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/karthink/popper")
+      (synopsis "Emacs minor-mode to summon and dismiss buffers easily")
+      (description
+       "Popper is a minor-mode to tame the flood of ephemeral
+windows Emacs produces, while still keeping them within arm’s reach.")
+      (license license:gpl3+))))
+
 (define-public emacs-python-black
   (package
     (name "emacs-python-black")
-- 
2.32.0