diff mbox series

[bug#56193] Add Climate Data Operators package

Message ID 87a6a26sai.fsf@burningswell.com
State Accepted
Headers show
Series [bug#56193] Add Climate Data Operators package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Roman Scherer June 24, 2022, 2:28 p.m. UTC
Hello Guix,

I would like to contribute a patch to add the Climate Data Operators
package to Guix's geo module. Could you please review it?

Thanks, Roman.

Comments

Antero Mejr June 24, 2022, 7:10 p.m. UTC | #1
Hi Roman,

NetCDF support isn't working in your patch. The software says this:

"Unsupported file type (library support not compiled in)
To create a CDO application with NetCDF support use:
./configure --with-netcdf=<NetCDF root directory> ..."

So it looks like you will have to modify the configure phase a little.

I don't think you need the expression
`(modules '((guix build utils))`
as you are not using that module in your source expression.

`licenses` doesn't have to be a list unless cdo is dual-licensed.

Please run `guix style` and `guix lint` (using pre-inst-env), which will
help make sure the code style follows the Guix style guidelines.

Thanks,
Antero
diff mbox series

Patch

From 2674303750a84b99d574212fe24c47e7e789f72e Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Fri, 24 Jun 2022 16:21:21 +0200
Subject: [PATCH] Add Climate Data Operators package

This PR adds CDO, a collection of command line Operators to manipulate and
analyse Climate and NWP model Data to Guix's geo module.
---
 gnu/packages/geo.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7b29c55088..64b5a91a23 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -119,6 +119,31 @@  (define-module (gnu packages geo)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public cdo
+  (package
+    (name "cdo")
+    (version "2.0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://code.mpimet.mpg.de/attachments/download/26823/cdo-"
+                     version ".tar.gz"))
+              (sha256
+               (base32
+                "1khdbd5cmnn7qm6hcqg4md5wbq14fs6brrns8b3g18diqgqvpvpd"))
+              (modules '((guix build utils)))))
+    (build-system gnu-build-system)
+    (inputs
+     (list netcdf))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://code.mpimet.mpg.de/projects/cdo")
+    (synopsis "Climate Data Operators")
+    (description "CDO is a collection of command line Operators to manipulate and analyse
+Climate and NWP model Data. Supported data formats are GRIB 1/2, netCDF 3/4,
+SERVICE, EXTRA and IEG. There are more than 600 operators available.")
+    (license (list license:bsd-3))))
+
 (define-public memphis
   (package
     (name "memphis")
-- 
2.36.1