diff mbox series

[bug#69015,1/2] gnu: go-go-etcd-io-bbolt: Move to (gnu packages golang).

Message ID 878r3sb4x7.fsf@troyfigiel.com
State New
Headers show
Series Deprecate the go-etcd-io-bbolt variable. | expand

Commit Message

Troy Figiel Feb. 10, 2024, 4:40 p.m. UTC
* gnu/packages/databases.scm (go-go-etcd-io-bbolt): Move from here ...
* gnu/packages/golang.scm: ... to here.
---
 gnu/packages/databases.scm | 28 ----------------------------
 gnu/packages/golang.scm    | 28 ++++++++++++++++++++++++++++
 2 files changed, 28 insertions(+), 28 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 903088ed4b..0345505ec1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2946,34 +2946,6 @@  (define-public libpqxx
     (home-page "https://pqxx.org/")
     (license license:bsd-3)))
 
-(define-public go-go-etcd-io-bbolt
-  (package
-    (name "go-go-etcd-io-bbolt")
-    (version "1.3.6")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/etcd-io/bbolt")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "go.etcd.io/bbolt"
-       ;; Extending the test timeout to 30 minutes still times out on aarch64.
-       #:tests? ,(not target-arm?)))
-    (propagated-inputs
-     (list go-golang-org-x-sys))
-    (home-page "https://go.etcd.io/bbolt")
-    (synopsis "Embedded key/value database for Go")
-    (description "Bolt is a pure Go key/value store inspired by Howard Chu's
-LMDB project.  The goal of the project is to provide a simple, fast, and
-reliable database for projects that don't require a full database server such as
-Postgres or MySQL.")
-    (license license:expat)))
-
 (define-public python-peewee
   (package
     (name "python-peewee")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..2b5a447c5d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9328,6 +9328,34 @@  (define-public go-github-com-zclconf-go-cty
 configuration languages, but other uses may be possible too.")
     (license license:expat)))
 
+(define-public go-go-etcd-io-bbolt
+  (package
+    (name "go-go-etcd-io-bbolt")
+    (version "1.3.6")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/etcd-io/bbolt")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "go.etcd.io/bbolt"
+       ;; Extending the test timeout to 30 minutes still times out on aarch64.
+       #:tests? ,(not target-arm?)))
+    (propagated-inputs
+     (list go-golang-org-x-sys))
+    (home-page "https://go.etcd.io/bbolt")
+    (synopsis "Embedded key/value database for Go")
+    (description "Bolt is a pure Go key/value store inspired by Howard Chu's
+LMDB project.  The goal of the project is to provide a simple, fast, and
+reliable database for projects that don't require a full database server such as
+Postgres or MySQL.")
+    (license license:expat)))
+
 (define-public go-etcd-io-bbolt
   (package
     (name "go-etcd-io-bbolt")