diff mbox series

[bug#40747] New package: r-mstate

Message ID 877dy8reen.fsf@ericcbrown.com
State Accepted
Headers show
Series [bug#40747] New package: r-mstate | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Eric Brown April 21, 2020, 4:29 p.m. UTC
Dear Guix:

Please see attached diff for r-mstate.

Best regards,
Eric

Comments

Leo Famulari May 29, 2020, 3:45 a.m. UTC | #1
On Tue, Apr 21, 2020 at 11:29:04AM -0500, Eric Brown wrote:
> Please see attached diff for r-mstate.

Thanks! Pushed as 3bafa88b40483040e5f8034561590cadd43514c8
diff mbox series

Patch

From 69141a3f79452e9a022b20e1b05b565e819386a2 Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Tue, 21 Apr 2020 11:20:16 -0500
Subject: [PATCH] gnu: Add r-mstate.

* gnu/packages/cran.scm (r-mstate): New variable.
---
 gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cb7cc700..935442b4ef 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21162,3 +21162,29 @@  evaluated interactively.")
 Bayes factors, posterior model probabilities, and normalizing constants in
 general, via different versions of bridge sampling.")
     (license license:gpl2+)))
+
+(define-public r-mstate
+  (package
+    (name "r-mstate")
+    (version "0.2.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mstate" version))
+       (sha256
+        (base32
+         "0qnhivbibzss8yfsg44cvbf73n4jj4i28rbdysl88g14ig5sabgv"))))
+    (properties `((upstream-name . "mstate")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-survival" ,r-survival)))
+    (home-page
+     "https://www.lumc.nl/org/bds/research/medische-statistiek/survival-analysis/")
+    (synopsis
+     "Data Preparation, Estimation and Prediction in Multi-State Models")
+    (description
+     "Contains functions for data preparation, descriptives, hazard estimation
+and prediction with Aalen-Johansen or simulation in competing risks and
+multi-state models.")
+    (license license:gpl2+)))
-- 
2.26.2