diff mbox series

[bug#55758] reproducible builds: keyutils: avoid embedding timestamp

Message ID 877d60au45.fsf@contorta
State Accepted
Headers show
Series [bug#55758] reproducible builds: keyutils: avoid embedding timestamp | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vagrant Cascadian June 1, 2022, 10:36 p.m. UTC
This completely removes a timestamp from the build of keyutils,
following the recommendation of:

  https://reproducible-builds.org/docs/timestamps/

  "Timestamps are best avoided"

Alternately, one could hard-code a specific timestamp (e.g. 2012-04-18),
or patch it to use the SOURCE_DATE_EPOCH environment variable (which
might at least be acceptible to submit upstream), although since
SOURCE_DATE_EPOCH is always 0 in guix, this seems a bit silly to me. :)


live well,
  vagrant

Comments

Ludovic Courtès June 4, 2022, 8:39 a.m. UTC | #1
Hi,

Vagrant Cascadian <vagrant@reproducible-builds.org> skribis:

> Alternately, one could hard-code a specific timestamp (e.g. 2012-04-18),
> or patch it to use the SOURCE_DATE_EPOCH environment variable (which
> might at least be acceptible to submit upstream), although since
> SOURCE_DATE_EPOCH is always 0 in guix, this seems a bit silly to me. :)

Yup.  :-)

> From 36888e9dc33188115142ecde9d31eb3884004940 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
> Date: Wed, 1 Jun 2022 09:24:00 -0700
> Subject: [PATCH 3/4] gnu: keyutils: Avoid embedding build timestamp.
>
> * gnu/packages/crypto.scm (keyutils)[arguments]: Add
>   'avoid-embedding-timestamp phase.

LGTM, thanks!

Ludo’.
Vagrant Cascadian June 6, 2022, 5:26 a.m. UTC | #2
On 2022-06-04, Ludovic Courtès wrote:
> Vagrant Cascadian <vagrant@reproducible-builds.org> skribis:
>> From 36888e9dc33188115142ecde9d31eb3884004940 Mon Sep 17 00:00:00 2001
>> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
>> Date: Wed, 1 Jun 2022 09:24:00 -0700
>> Subject: [PATCH 3/4] gnu: keyutils: Avoid embedding build timestamp.
>>
>> * gnu/packages/crypto.scm (keyutils)[arguments]: Add
>>   'avoid-embedding-timestamp phase.
>
> LGTM, thanks!

Pushed as 32322d0926313d28276928d81188ee909e464eb0!

live well,
  vagrant
diff mbox series

Patch

From 36888e9dc33188115142ecde9d31eb3884004940 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Wed, 1 Jun 2022 09:24:00 -0700
Subject: [PATCH 3/4] gnu: keyutils: Avoid embedding build timestamp.

* gnu/packages/crypto.scm (keyutils)[arguments]: Add
  'avoid-embedding-timestamp phase.
---
 gnu/packages/crypto.scm | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index e98d9634dc..6e4b1331e7 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -398,6 +398,11 @@  (define-public keyutils
            #:phases
            #~(modify-phases %standard-phases
                (delete 'configure)      ; no configure script
+               (add-after 'unpack 'avoid-embedding-timestamp
+                 ;; Do not embed build timestamp
+                 (lambda _
+                   (substitute* "Makefile"
+                     (("shell date") "shell true"))))
                (add-after 'install 'install:static
                  (lambda _
                    (with-directory-excursion #$output
-- 
2.35.1