[bug#34382,4/5] gnu: Add python-docstyle.

Message ID 875ztusyxz.fsf@posteo.net
State Accepted
Headers show
Series [bug#34379,1/5] gnu: python2-rope: Change comment to reflect partial | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Brett Gilio Feb. 8, 2019, 4:10 a.m. UTC

Comments

Ludovic Courtès Feb. 12, 2019, 10:33 p.m. UTC | #1
Brett Gilio <brettg@posteo.net> skribis:

>>From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Thu, 7 Feb 2019 22:04:52 -0600
> Subject: [PATCH 4/5] gnu: Add python-docstyle.
>
> * gnu/packages/python-xyz.scm (python-docstyle): New variable.

Pushed as well.

This series ended up taking me more time than I thought.  :-)
First the patches were sent in reverse order, which I only realized
later.  Then each patch had tiny issues (indentation, inappropriate
description, code duplication, etc.) that I ended up fixing because they
looked tiny at first…

Please pay more attention to these things in the future.

Regardless, thank you for the patches!

Ludo’.
Brett Gilio Feb. 13, 2019, 12:50 a.m. UTC | #2
Ludovic Courtès writes:

> Brett Gilio <brettg@posteo.net> skribis:
>
>>>From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Thu, 7 Feb 2019 22:04:52 -0600
>> Subject: [PATCH 4/5] gnu: Add python-docstyle.
>>
>> * gnu/packages/python-xyz.scm (python-docstyle): New variable.
>
> Pushed as well.
>
> This series ended up taking me more time than I thought.  :-)
> First the patches were sent in reverse order, which I only realized
> later.  Then each patch had tiny issues (indentation, inappropriate
> description, code duplication, etc.) that I ended up fixing because they
> looked tiny at first…
>
> Please pay more attention to these things in the future.
>
> Regardless, thank you for the patches!
>
> Ludo’.

Thank you Ludo,

This was my first series, so I appreciate the comments you gave me for
feedback and I will be more diligent in the future!

Brett
Brett Gilio Feb. 13, 2019, 12:51 a.m. UTC | #3
Ludovic Courtès writes:

> Brett Gilio <brettg@posteo.net> skribis:
>
>>>From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Thu, 7 Feb 2019 22:04:52 -0600
>> Subject: [PATCH 4/5] gnu: Add python-docstyle.
>>
>> * gnu/packages/python-xyz.scm (python-docstyle): New variable.
>
> Pushed as well.
>
> This series ended up taking me more time than I thought.  :-)
> First the patches were sent in reverse order, which I only realized
> later.  Then each patch had tiny issues (indentation, inappropriate
> description, code duplication, etc.) that I ended up fixing because they
> looked tiny at first…
>
> Please pay more attention to these things in the future.
>
> Regardless, thank you for the patches!
>
> Ludo’.

This was my first patch series, so I appreciate your feedback to help me
make sure that I am doing this correct in the future!

Thank you as always

Patch

From 0b66f38dd41230611cad44181a81bda38e40619f Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 7 Feb 2019 22:04:52 -0600
Subject: [PATCH 4/5] gnu: Add python-docstyle.

* gnu/packages/python-xyz.scm (python-docstyle): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5c7241621..c41c4a1cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2545,6 +2545,27 @@  Language (TOML) configuration files.")
   (description "An implementation of the JSON RPC 2.0 server library for interoperability with Python.")
   (license license:expat)))
 
+(define-public python-pydocstyle
+  (package
+  (name "python-pydocstyle")
+  (version "3.0.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "pydocstyle" version))
+      (sha256
+        (base32
+          "1m1xv9clkg9lgzyza6dnj359z04vh5g0h49nhzghv7lg81gchhap"))))
+  (build-system python-build-system)
+  (propagated-inputs
+   `(("python-six" ,python-six)
+     ("python-snowballstemmer" ,python-snowballstemmer)))
+  (home-page
+    "https://github.com/PyCQA/pydocstyle/")
+  (synopsis "Python docstring style checker")
+  (description "A docstring style checker/linter for the Python language server.")
+  (license license:expat)))
+
 (define-public python-black
   (package
     (name "python-black")
-- 
2.20.1