[bug#34383,5/5] gnu: Add python-rope.

Message ID 8736oysyxo.fsf@posteo.net
State Accepted
Headers show
Series [bug#34379,1/5] gnu: python2-rope: Change comment to reflect partial | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brett Gilio Feb. 8, 2019, 4:10 a.m. UTC

Comments

Ludovic Courtès Feb. 12, 2019, 10:18 p.m. UTC | #1
Brett Gilio <brettg@posteo.net> skribis:

>>From 1d3915a1ba301740fab830fccbe92062f7351f95 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Thu, 7 Feb 2019 22:05:19 -0600
> Subject: [PATCH 5/5] gnu: Add python-rope.
>
> * gnu/packages/python-xyz.scm (python-rope): New variable.
> ---
>  gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index c41c4a1cd..4ffb59f5e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -2566,6 +2566,29 @@ Language (TOML) configuration files.")
>    (description "A docstring style checker/linter for the Python language server.")
>    (license license:expat)))
>  
> +(define-public python-rope
> +  (package
> +  (name "python-rope")
> +  (version "0.11.0")
> +  (source
> +    (origin
> +      (method url-fetch)
> +      (uri (pypi-uri "rope" version))
> +      (sha256
> +        (base32
> +          "1cppm0pa9aqgsbkq130lskrzmrvjs5vpiavjjbhpz2fdw52w8251"))))
> +  (build-system python-build-system)
> +  (arguments
> +   `(#:tests? #f)) ; Only partial python3 support, results in some failing tests
> +  ;; https://github.com/python-rope/rope/issues/247
> +  (home-page "https://github.com/python-rope/rope")
> +  (synopsis "A refactoring library for Python")
> +  (description "Rope is a refactoring library for Python.  It facilitates
> +the renaming, moving and extracting of attributes, functions, modules, fields
> +and parameters in Python 3 source code.  These refactorings can also be applied
> +to occurrences in strings and comments.")
> +  (license license:gpl2)))

This is duplicating all of ‘python2-rope’, so I ended up simply
inheriting from ‘python2-rope’.

Thanks,
Ludo’.

Patch

From 1d3915a1ba301740fab830fccbe92062f7351f95 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 7 Feb 2019 22:05:19 -0600
Subject: [PATCH 5/5] gnu: Add python-rope.

* gnu/packages/python-xyz.scm (python-rope): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c41c4a1cd..4ffb59f5e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2566,6 +2566,29 @@  Language (TOML) configuration files.")
   (description "A docstring style checker/linter for the Python language server.")
   (license license:expat)))
 
+(define-public python-rope
+  (package
+  (name "python-rope")
+  (version "0.11.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "rope" version))
+      (sha256
+        (base32
+          "1cppm0pa9aqgsbkq130lskrzmrvjs5vpiavjjbhpz2fdw52w8251"))))
+  (build-system python-build-system)
+  (arguments
+   `(#:tests? #f)) ; Only partial python3 support, results in some failing tests
+  ;; https://github.com/python-rope/rope/issues/247
+  (home-page "https://github.com/python-rope/rope")
+  (synopsis "A refactoring library for Python")
+  (description "Rope is a refactoring library for Python.  It facilitates
+the renaming, moving and extracting of attributes, functions, modules, fields
+and parameters in Python 3 source code.  These refactorings can also be applied
+to occurrences in strings and comments.")
+  (license license:gpl2)))
+
 (define-public python-black
   (package
     (name "python-black")
-- 
2.20.1