diff mbox series

[bug#41327] gnu: Add emacs-vcsh.

Message ID 875zcsxd92.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41327] gnu: Add emacs-vcsh. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder May 19, 2020, 1:31 p.m. UTC
Hi Nicolas,

thank you for reviewing the patch.

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>> +        (base32
>> +         "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))
>
> Nitpick: could you move the string on the line above?

done.

>> +    (description
>> +     "This library only provides basic \"enter\" functionality
>> +(`vcsh-link', `vcsh-unlink') and a few convenience commands
>> +(`vcsh-new' to init a repo and add files to it,
>> +`vcsh-write-gitignore').
>
> Without writing too many details, I suggest
>
>   This library provides basic ``enter'' functionality and a few
>   convenience commands to init a repository and add files to it.
>
> However, it may be useful to write somewhere what is "vcsh". As a user,
> do I need/want that?

I modified the description to your suggesting and added a short
sentence, why/how this package could be useful.

e.g. I use it in this function (that i call from a hydra):
> Could you send an updated patch?
Regards,

Comments

Nicolas Goaziou May 20, 2020, 10:44 a.m. UTC | #1
Hello,

Michael Rohleder <mike@rohleder.de> writes:

> * gnu/packages/emacs-xyz.scm (emacs-vcsh): New variable.

I tweaked the description and applied your patch.

Thank you!

Regards,
diff mbox series

Patch

From 43a46ffd415ff780eda5dfeb5bd8de8ebaa04259 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Tue, 19 May 2020 15:05:16 +0200
Subject: [PATCH] gnu: Add emacs-vcsh.

* gnu/packages/emacs-xyz.scm (emacs-vcsh): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 69786f335b..77ab2977ee 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14919,6 +14919,28 @@  repository, @code{magit-org-todos} will create a section in your Magit status
 buffer with each of your todos.")
       (license license:gpl3+))))
 
+(define-public emacs-vcsh
+  (package
+    (name "emacs-vcsh")
+    (version "0.4.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/stepnem/vcsh-el.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))
+    (build-system emacs-build-system)
+    (home-page "https://gitlab.com/stepnem/vcsh-el")
+    (synopsis "Emacs vcsh integration")
+    (description
+     "This library provides basic \"enter\" functionality and a few
+convenience commands to init a repo and add files to it.  This is useful to
+use @code{magit} with a @code{vcsh} repo.")
+    (license license:public-domain)))
+
 (define-public emacs-f3
   (package
     (name "emacs-f3")
-- 
2.26.2