diff mbox series

[bug#44831] Acknowledgement (Add emacs-gn-mode)

Message ID 875z5vzn6j.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#44831] Acknowledgement (Add emacs-gn-mode) | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti Nov. 23, 2020, 11:08 p.m. UTC
And here's the patch I forgot to attach
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 44831@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> -- 
> 44831: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=44831
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems

Comments

Nicolas Goaziou Nov. 24, 2020, 8:18 a.m. UTC | #1
Hello,

Nicolò Balzarotti <anothersms@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-gn-mode): New variable.

Thank you. I moved the home page, as it is usually located above the
synopsis, slightly tweaked the description, and applied it.

Regards,
diff mbox series

Patch

From 3f57b032ca5a91e33fde419c4af1df1806c06998 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Mon, 23 Nov 2020 23:34:46 +0100
Subject: [PATCH] gnu: Add emacs-gn-mode.

* gnu/packages/emacs-xyz.scm (emacs-gn-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5f49c64bb7..1c9dd48518 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -85,6 +85,7 @@ 
 ;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
 ;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
 ;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
+;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10602,6 +10603,27 @@  provides functions to convert hash tables from and to alists and plists.")
 you to deal with multiple log levels.")
     (license license:gpl3+)))
 
+(define-public emacs-gn-mode
+  (package
+    (name "emacs-gn-mode")
+    (version "0.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lashtear/gn-mode")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0dz5kgzbgsssr38z2kg6m915cvfys42ag1k42bsra3la2pixywfx"))))
+    (build-system emacs-build-system)
+    (synopsis "Major-mode for editing GN (ninja generator) config files in Emacs")
+    (description "GN-mode is a major-mode for editing @acronym{GN,Ninja
+Generator} config files in Emacs.  Files of this type (e.g. @file{BUILD.gn} or
+@code{*.gni}) are common in Chromium-derived projects.")
+    (home-page "https://github.com/lashtear/gn-mode")
+    (license license:bsd-3)))
+
 (define-public emacs-gntp
   (package
     (name "emacs-gntp")
-- 
2.29.2