diff mbox series

[bug#48642] Add kanatest

Message ID 875yz75hsh.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#48642] Add kanatest | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti May 25, 2021, 8:39 a.m. UTC
Hi! Thanks for the fast review!

Xinglu Chen <public@yoctocell.xyz> writes:

> On Tue, May 25 2021, Nicolò Balzarotti wrote:
>
>> +(define-public kanatest
>> +  ;; Latest release tarball is 0.4.8, which is really old and does not build
>> +  ;; commit on sourceforge are not tagged, we take the latest
>> +  (let ((commit "860e790a35f547cc96669f805d371a5ba3d8daff"))
>> +    (package
>> +      (name "kanatest")
>> +      (version (string-append "0.4.10." (string-take commit 7)))
>
> Use ‘(git-version VERSION REVISION COMMIT)’.
>
I added revision "0" along with commit in the let block and used
git-version as suggested.

>> [...]
>> +      (home-page "https://kanatest.sourceforge.io/")
>
> Nit: ‘home-page’ usually comes before ‘synopsis’.
>
Moved above!

> Otherwise, LGTM!  Builds fine as well.

Thanks, here's version 2 of the patch!

Thanks again for the review,
Nicolò

Comments

Xinglu Chen May 25, 2021, 9:03 a.m. UTC | #1
On Tue, May 25 2021, Nicolò Balzarotti wrote:

> Hi! Thanks for the fast review!
>
> [...]
>
> Thanks, here's version 2 of the patch!
>
> Thanks again for the review,

You are welcome!  The changes look good, I don’t have commit access,
though.
Nicolas Goaziou May 25, 2021, 10:12 a.m. UTC | #2
Hello,

Nicolò Balzarotti <anothersms@gmail.com> writes:

> Thanks, here's version 2 of the patch!

I added a copyright line for you and applied the patch. Thank you!
>
> Thanks again for the review,

Indeed, thank you, Xinglu Chen.

Regards,
diff mbox series

Patch

From e40dcce2eb93a033124fb5bcdb7c0be87e63313c Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Tue, 25 May 2021 09:02:41 +0200
Subject: [PATCH v2] gnu: Add kanatest.

* gnu/packages/education.scm (kanatest): New variable.
---
 gnu/packages/education.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index cd28e35b78..266dc89bdd 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -865,6 +865,43 @@  languages and keyboard layouts, and typing statistics are used to dynamically
 adjust the level of difficulty.")
     (license license:gpl2)))
 
+(define-public kanatest
+  ;; Latest release tarball is 0.4.8, which is really old and does not build
+  ;; commit on sourceforge are not tagged, we take the latest
+  (let ((commit "860e790a35f547cc96669f805d371a5ba3d8daff")
+        (revision "0"))
+    (package
+      (name "kanatest")
+      (version (git-version "0.4.10" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.code.sf.net/p/kanatest/code")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0dz63m9p4ggzw0yb309qmgnl664qb5q268vaa3i9v0i8qsl66d78"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("gettext" ,gettext-minimal)   ; for msgfmt
+         ("pkg-config" ,pkg-config)))
+      (inputs
+       `(("libxml2" ,libxml2)
+         ("gtk+" ,gtk+)))
+      (home-page "https://kanatest.sourceforge.io/")
+      (synopsis "Hiragana and Katakana simple flashcard tool")
+      (description "Kanatest is a Japanese kana (Hiragana and Katakana) simple
+flashcard tool.
+
+During test the Kanatest displays randomly selected kana char (respecting mode
+and lesson) and waits for user answer expected as romaji equivalent.  This
+process continues until all questions will be answered or all questions will
+be answered correctly (depends on options).  At the end of test a short info
+about drilling time and correctness ratio is displayed.  The results are
+stored and user can review his performance in any time.")
+      (license license:gpl2+))))
+
 (define-public anki
   (package
     (name "anki")
-- 
2.31.1