diff mbox series

[bug#48818,1/2] gnu: Add emacs-flymake-quickdef.

Message ID 875yyud4hu.fsf@posteo.net
State Accepted
Headers show
Series gnu: Add emacs-flymake-kondor. | expand

Commit Message

Aleksandr Vityazev June 3, 2021, 9:26 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-flymake-quickdef): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7d985c0d0f..2541c148ad 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28272,3 +28272,32 @@  to the https://multitran.com online dictionary.")
 Leiningen plugin for detecting and improving non-idiomatic
 Clojure source code, from within GNU Emacs. ")
       (license license:gpl3+))))
+
+(define-public emacs-flymake-quickdef
+  (let ((version "1.0.0")
+        (revision "0")
+        (commit "150c5839768a3d32f988f9dc08052978a68f2ad7"))
+    (package
+      (name "emacs-flymake-quickdef")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/karlotness/flymake-quickdef")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "19gfd539l97j8xbrq1fw83b54mxbcamlz9m896088d3p01zf8b0g"))))
+      (build-system emacs-build-system)
+      (home-page
+       "https://github.com/karlotness/flymake-quickdef")
+      (synopsis "Quickly define a new Flymake backend")
+      (description
+       "This package mainly defines @code{flymake-quickdef-backend}, a macro
+which helps remove some of the boilerplate code from defining new
+Flymake backend functions.  The macro defines a function which is
+suitable for use with @code{flymake-diagnostic-functions} and handles
+running the external process, creating and removing any necessary
+files and buffers, and regex matches against diagnostic output. ")
+      (license license:gpl3+))))