diff mbox series

[bug#48818,2/2] gnu: Add emacs-flymake-kondor.

Message ID 874keed4hm.fsf@posteo.net
State Accepted
Headers show
Series gnu: Add emacs-flymake-kondor. | expand

Commit Message

Aleksandr Vityazev June 3, 2021, 9:26 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-flymake-kondor): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Nicolas Goaziou June 5, 2021, 12:27 p.m. UTC | #1
Hello,

Alexandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-flymake-kondor): New variable.

Applied, with the patch before it. Thank you.

> +(define-public emacs-flymake-kondor
> +  (let ((version "0.0.3")
> +        (revision "0")
> +        (commit "72052b5ba827faf357608cf720a70221192a8282"))

This commit is exactly tagged "0.0.3" release. So I used that instead.

> +      (description
> +       "This package adds Clojure syntax checker clj-kondo. ")

Please mind the trailing white space.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2541c148ad..1892d06960 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28301,3 +28301,30 @@  suitable for use with @code{flymake-diagnostic-functions} and handles
 running the external process, creating and removing any necessary
 files and buffers, and regex matches against diagnostic output. ")
       (license license:gpl3+))))
+
+(define-public emacs-flymake-kondor
+  (let ((version "0.0.3")
+        (revision "0")
+        (commit "72052b5ba827faf357608cf720a70221192a8282"))
+    (package
+      (name "emacs-flymake-kondor")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/turbo-cafe/flymake-kondor")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0h8dqk35r10pxx2w4swb3kij4y2vi17j9wfk978x8lf0wd3h3hsy"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-flymake-quickdef"
+          ,emacs-flymake-quickdef)))
+      (home-page
+       "https://github.com/turbo-cafe/flymake-kondor")
+      (synopsis "Linter with clj-kondo")
+      (description
+       "This package adds Clojure syntax checker clj-kondo. ")
+      (license license:gpl3+))))