diff mbox series

bug#68448: Add guile-rsv package definition.

Message ID 875xwgjr2n.fsf_-_@gnu.org
State New
Headers show
Series bug#68448: Add guile-rsv package definition. | expand

Commit Message

Ludovic Courtès April 17, 2024, 9:06 a.m. UTC
Hi Yulav,

Yuval Langer <yuval.langer@gmail.com> skribis:

> I have:
>
> - Replaced the square brackets with parentheses in the let
>   definitions,
> - added a revision number and used `git-version`,
> - rewrote the synopsis and description,
> - checked the style with `guix style -L . guile-rsv` in my own Guix
>   channel with this guile-rsv package definition, which seems to show
>   no style errors or recommendations, and
>
> I hope these are sufficient.

Apologies for the long delay.  I made the cosmetic changes below, added
a commit log, and committed it.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 874dd3d98a..c0b0dfd78c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -5498,21 +5498,19 @@  (define-public guile-eris
 
 (define-public guile-rsv
   (let ((commit "41b04c85eef31d4d51001c6d66e8fd339fcc614c")
-        (revision "1")
-        (base32-string "1w9jbkpmh13zrxkj915nm3l537smm0jsrdzrzcxylb6w59vqpw6l")
-        (git-repository-url "https://codeberg.org/kakafarm/guile-rsv/"))
+        (revision "1"))
     (package
       (name "guile-rsv")
       (version (git-version "0.2.0" revision commit))
+      (home-page "https://codeberg.org/kakafarm/guile-rsv/")
       (source
        (origin
-         (uri (git-reference
-               (url git-repository-url)
-               (commit commit)))
+         (uri (git-reference (url home-page) (commit commit)))
          (method git-fetch)
          (file-name (git-file-name name version))
          (sha256
-          (base32 base32-string))))
+          (base32
+           "1w9jbkpmh13zrxkj915nm3l537smm0jsrdzrzcxylb6w59vqpw6l"))))
       (inputs (list guile-3.0 bash))
       (build-system guile-build-system)
       (arguments
@@ -5530,9 +5528,9 @@  (define-public guile-rsv
                            (mkdir-p bin)
                            (for-each (lambda (command-name)
                                        (let ((source-script (string-append #$output
-                                                             scm "/"
-                                                             command-name
-                                                             ".scm"))
+                                                                           scm "/"
+                                                                           command-name
+                                                                           ".scm"))
                                              (target-command (string-append
                                                               bin "/"
                                                               command-name)))
@@ -5544,22 +5542,19 @@  (define-public guile-rsv
                                            `("GUILE_LOAD_COMPILED_PATH" prefix
                                              (,(string-append #$output go))))))
                                      (list "scm2rsv" "rsv2scm"))))))))
-      (home-page git-repository-url)
-      (synopsis
-       "Library for reading and writing Rows of String Values data format")
+      (synopsis "Reading and writing @acronym{RSV, rows of string values} data format")
       (description
-       "R7RS-small Scheme library for reading and writing RSV (Rows of String
-Values) data format, a very simple binary format for storing tables of
-strings.  It is a competitor for e.g. CSV (Comma Seperated Values),
-and TSV (Tab Separated Values).  Its main benefit is that the strings
-are represented as Unicode encoded as UTF-8, and the value and row
-separators are byte values that are never used in UTF-8, so the
-strings do not need any error prone escaping and thus can be written
-and read verbatim.
+       "R7RS-small Scheme library for reading and writing @acronym{RSV, rows
+of string values} data format, a very simple binary format for storing tables
+of strings.  It is a competitor for CSV (Comma Seperated Values) and TSV (Tab
+Separated Values).  Its main benefit is that the strings are represented as
+Unicode encoded as UTF-8, and the value and row separators are byte values
+that are never used in UTF-8, so the strings do not need any error prone
+escaping and thus can be written and read verbatim.
 
-Specified in https://github.com/Stenway/RSV-Specification and
-demonstrated in https://www.youtube.com/watch?v=tb_70o6ohMA.")
-      (license (list license:gpl3+ license:expat-0)))))
+The RSV format is specified in
+@url{https://github.com/Stenway/RSV-Specification}.")
+      (license license:gpl3+))))
 
 (define-public guile-r6rs-protobuf
   (package