diff mbox series

[bug#40258] gnu: Add emacs-flycheck-elm.

Message ID 87369pwvd6.fsf@asu.edu
State Accepted
Headers show
Series [bug#40258] gnu: Add emacs-flycheck-elm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

John Soo March 30, 2020, 6:28 p.m. UTC
Hi Nicolas,

Thanks again!

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

>> +;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
>
> You can remove this line, already applied in a previous patch.

I rebased on master so that should not be in this patch.


>> +(define-public emacs-flycheck-elm
>> +  (package
>> +    (name "emacs-flycheck-elm")
>> +    (version "debd0af")
>
> This is not a proper version string (not monotonic). You should bind
> `commit' to "debd0af563cb6c2944367a691c7fa3021d9378c1" and `revision' to
> "O" at the top of your package definition, and use
>
>   (version (git-version "0" revision commit))
>
>> +         (commit version)))
>
> In the case above, this should be:
>
>   (commit commit)

Done, thank you! I was confused what version to use there.

>> +    (inputs
>> +     `(("emacs-flycheck" ,emacs-flycheck)
>> +       ("emacs-let-alist" ,emacs-let-alist)
>> +       ("emacs-seq" ,emacs-seq)))
>
> I don't think you need "emacs-seq" since we build packages with Emacs
> 26.3, which includes "seq.el" already.

It builds just fine without seq, so I removed it.

>> +    (build-system emacs-build-system)
>> +    (home-page "https://github.com/bsermons/flycheck-elm")
>> +    (synopsis "Flycheck support for the elm language")
>> +    (description "Flycheck support for the elm language.")
>
> Nitpick: I would use Elm.

Done.

> The description needs to be a full sentence.

Done. Though there really is not much there. It might need revision.

>> +    (license license:gpl2+)))
>
> All source code files are GPL3+, so this probably makes the project
> GPL3+ licensed. LICENSE file is GPL2 (not 2+), but I would trust source
> code in this case.
>
> You may want to tell upstream about this discrepancy.

I reported the issue and put a comment over the license field.

> Could you send an updated patch?

Updated patch attached.

Thanks so much,

John
diff mbox series

Patch

From b3a7da54b71adaf0323a73b77c5c36983c80ada4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:57:31 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-elm.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c029d1ed3d..f62e075e76 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21965,3 +21965,31 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-flycheck-elm
+  (let ((revision "0")
+        (commit "debd0af563cb6c2944367a691c7fa3021d9378c1"))
+   (package
+    (name "emacs-flycheck-elm")
+    (version (git-version "0" revision commit))
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/bsermons/flycheck-elm")
+         (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1vl0lss2n50pz5wscqj6vhjwb4hbg8xx2chh5vafsrnn0a3fryrd"))))
+    (inputs
+     `(("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-let-alist" ,emacs-let-alist)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/bsermons/flycheck-elm")
+    (synopsis "Flycheck support for the Elm")
+    (description "Flycheck-elm adds flycheck support for Elm.")
+    ;; License file out of sync with source
+    ;; See https://github.com/bsermons/flycheck-elm/issues/18
+    (license license:gpl3+))))
-- 
2.26.0