diff mbox series

[bug#44832] Add emacs dart-mode

Message ID 87360zzn4t.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#44832] Add emacs dart-mode | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti Nov. 23, 2020, 11:09 p.m. UTC
Patch that adds an emacs mode for editing .dart files.

Thanks!

Comments

Nicolas Goaziou Nov. 24, 2020, 8:38 a.m. UTC | #1
Hello,

Nicolò Balzarotti <anothersms@gmail.com> writes:

> Patch that adds an emacs mode for editing .dart files.

Thank you.

I switched license to GPL3+ (I don't think it is GPL3 only, but correct
me if I'm wrong), removed BSD-3 since tests are not carried over in the
package, and applied your patch.

Regards,
diff mbox series

Patch

From 9ed17d91a7751adc65a7ccd1972eec2e9650a96f Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Mon, 23 Nov 2020 23:42:29 +0100
Subject: [PATCH] gnu: Add emacs-dart-mode.

* gnu/packages/emacs-xyz.scm (emacs-dart-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c9dd48518..c929d6338a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10358,6 +10358,33 @@  Flx has support for ido (interactively do things) through flx-ido.")
 known loosely as deftheme.  Many mode-specific customizations are included.")
     (license license:gpl3+)))
 
+(define-public emacs-dart-mode
+  (package
+    (name "emacs-dart-mode")
+    (version "1.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/bradyt/dart-mode")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qmdlwjmmqyyb65sqvfpygifai5m0llc815vp0jqwp8ldd8ls172"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-s" ,emacs-s)))
+    (synopsis "Emacs mode for the Dart programming language")
+    (description "Dart-mode is an Emacs major mode for editing Dart files.  It
+provides basic syntax highlighting and indentation.")
+    (home-page "https://github.com/bradyt/dart-mode")
+    (license
+     (list license:gpl3
+           ;; Tests include dart code released under bsd-3
+           license:bsd-3))))
+
 (define-public emacs-danneskjold-theme
   (let* ((commit "8733d2fe8743e8a01826ea6d4430ef376c727e57")
          (revision "1"))
-- 
2.29.2