diff mbox series

[bug#54078,3/3] gnu: add wayvnc

Message ID 8735kcbptq.fsf_-_@disroot.org
State New
Headers show
Series gnu: add libaml, libneatvnc, and wayvnc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

kitzman Feb. 21, 2022, 8:12 a.m. UTC
I have attached the final patch in this series: wayvnc.

gnu/packages/vnc.scm:384 wayvnc
diff mbox series

Patch

From 51bb697e93fe88d1178de92e54a9895ca3a89ab9 Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Mon, 21 Feb 2022 10:04:17 +0200
Subject: [PATCH 3/3] gnu: add wayvnc

---
 gnu/packages/vnc.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index 5795ea525c..31409d9d30 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -384,3 +384,25 @@  (define-public libneatvnc
     (description "This is a liberally licensed VNC server library that's intended to be fast and neat.")
     (license license:isc)))
 
+(define-public wayvnc
+  (package
+    (name "wayvnc")
+    (version "0.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/wayvnc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "wayvnc" (string-append "v" version)))
+              (sha256
+               (base32
+                "0cws9jfnmxqycmlyllvvqzw4jsbrwwk10v9gy8wifv3c61rwgdkk"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config libaml libdrm scdoc))
+    (inputs
+     (list pixman libglvnd libxkbcommon libaml libneatvnc wayland))
+    (home-page "https://github.com/any1/wayvnc")
+    (synopsis "VNC server for wlroots-based Wayland compositors")
+    (description "This is a VNC server for wlroots-based Wayland compositors (no_entry Gnome and KDE are not supported). It attaches to a running Wayland session, creates virtual input devices, and exposes a single display via the RFB protocol. The Wayland session may be a headless one, so it is also possible to run wayvnc without a physical display attached.")
+    (license license:isc)))
-- 
2.32.0