From 51bb697e93fe88d1178de92e54a9895ca3a89ab9 Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Mon, 21 Feb 2022 10:04:17 +0200
Subject: [PATCH 3/3] gnu: add wayvnc
---
gnu/packages/vnc.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -384,3 +384,25 @@ (define-public libneatvnc
(description "This is a liberally licensed VNC server library that's intended to be fast and neat.")
(license license:isc)))
+(define-public wayvnc
+ (package
+ (name "wayvnc")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/any1/wayvnc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "wayvnc" (string-append "v" version)))
+ (sha256
+ (base32
+ "0cws9jfnmxqycmlyllvvqzw4jsbrwwk10v9gy8wifv3c61rwgdkk"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config libaml libdrm scdoc))
+ (inputs
+ (list pixman libglvnd libxkbcommon libaml libneatvnc wayland))
+ (home-page "https://github.com/any1/wayvnc")
+ (synopsis "VNC server for wlroots-based Wayland compositors")
+ (description "This is a VNC server for wlroots-based Wayland compositors (no_entry Gnome and KDE are not supported). It attaches to a running Wayland session, creates virtual input devices, and exposes a single display via the RFB protocol. The Wayland session may be a headless one, so it is also possible to run wayvnc without a physical display attached.")
+ (license license:isc)))
--
2.32.0