diff mbox series

[bug#54078,2/3] gnu: add libneatvnc

Message ID 877d9obpw6.fsf_-_@disroot.org
State New
Headers show
Series gnu: add libaml, libneatvnc, and wayvnc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

kitzman Feb. 21, 2022, 8:11 a.m. UTC
I have attached a patch for libneatvnc:

gnu/packages/vnc.scm:361 libneatvnc

Comments

M Feb. 21, 2022, 1:22 p.m. UTC | #1
kitzman via Guix-patches via schreef op ma 21-02-2022 om 10:11 [+0200]:
> +    (native-inputs
> +     (list pkg-config libdrm))

Looking at 'src/tight.c', 'libdrm' looks like a regular input to me,
not a native-input.  It needs to be in inputs, otherwise the cross-
compiler won't find libdrm's header when src/tight.c is being cross-
compiled.

> +    (propagated-inputs
> +     (list libglvnd libxkbcommon pixman libaml gnutls libjpeg-turbo
> zlib))

Is propagation necessary here?  Would regular inputs suffice?
(Propagation can cause propagation conflicts and other issues.)

> +    (home-page "https://github.com/any1/neatvnc")
> +    (synopsis "VNC server library that's intended to be fast and
> neat")
> +    (description "This is a liberally licensed VNC server library
> that's intended to be fast and neat.")

‘Liberally licensed’: the package definition has a 'license' field
that should be sufficient for the user to determine if they like the
license or not.  Also, please keep the descriptions descriptive, no
marketing phrases ‘liberal’, ‘fast, and ‘neat’ (from (guix)Synopses and
Descriptions):

  Please avoid marketing phrases such as “world-leading”,
  “industrial-strength”, and “next-generation”, and avoid superlatives
  like “the most advanced”—they are not helpful to users looking for a
  package and may even sound suspicious.  Instead, try to be factual,
  mentioning use cases and features.

Greetings,
Maxime.
diff mbox series

Patch

From 8998b04ee557c62c4ad7d1da671fb6b3c3141c90 Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Mon, 21 Feb 2022 10:04:00 +0200
Subject: [PATCH 2/3] gnu: add libneatvnc

---
 gnu/packages/vnc.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index c0fabe848b..5795ea525c 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -39,12 +39,15 @@  (define-module (gnu packages vnc)
   #:use-module (gnu packages fltk)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
+  #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -357,3 +360,27 @@  (define-public libvnc
 easily implement VNC server or client functionality in your program.")
     (license ;; GPL for programs, FDL for documentation
      (list license:gpl2+ license:fdl1.2+))))
+
+(define-public libneatvnc
+  (package
+    (name "libneatvnc")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/neatvnc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "neatvnc" (string-append "v" version)))
+              (sha256
+               (base32
+                "1wpq1vyjqra877vwc3n4i0c1dyhmabyn993cslf1k142ikyc0a8w"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config libdrm))
+    (propagated-inputs
+     (list libglvnd libxkbcommon pixman libaml gnutls libjpeg-turbo zlib))
+    (home-page "https://github.com/any1/neatvnc")
+    (synopsis "VNC server library that's intended to be fast and neat")
+    (description "This is a liberally licensed VNC server library that's intended to be fast and neat.")
+    (license license:isc)))
+
-- 
2.32.0