diff mbox series

[bug#61003] gnu: Add lzfse.

Message ID 86mt6avkcf.fsf@burningswell.com
State New
Headers show
Series [bug#61003] gnu: Add lzfse. | expand

Commit Message

Roman Scherer Jan. 22, 2023, 12:10 p.m. UTC
Hello Guix,

this patch adds the LZFSE package, a compression library and command line tool.

Could you please review it?

Thanks, Roman.

Comments

Raghav Gururajan Jan. 22, 2023, 5:41 p.m. UTC | #1
Roman,

Thanks for your patch. I'll have a look and merge it in the next days.

Regards,
Raghav "RG" Gururajan.
Nicolas Goaziou Feb. 11, 2023, 8:53 p.m. UTC | #2
Hello,

Roman Scherer <roman.scherer@burningswell.com> writes:

> this patch adds the LZFSE package, a compression library and command
> line tool.

Applied. Thank you.

Regards,
Roman Scherer Feb. 12, 2023, 7:19 a.m. UTC | #3
Thank you Nicolas

On Sat, Feb 11, 2023, 21:53 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> Hello,
>
> Roman Scherer <roman.scherer@burningswell.com> writes:
>
> > this patch adds the LZFSE package, a compression library and command
> > line tool.
>
> Applied. Thank you.
>
> Regards,
> --
> Nicolas Goaziou
>
diff mbox series

Patch

From fdb42eb6380706e06b1d02c5380ccca198da7583 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 22 Jan 2023 13:00:53 +0100
Subject: [PATCH] gnu: Add lzfse.

* gnu/packages/compression.scm (lzfse): New variable.
---
 gnu/packages/compression.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 0f4c9a794e..e84dee6ceb 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2807,6 +2807,29 @@  (define-public libcbor
     (license license:expat)
     (home-page "https://github.com/PJK/libcbor")))
 
+(define-public lzfse
+  (package
+    (name "lzfse")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lzfse/lzfse.git")
+             (commit (string-append "lzfse-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1mfh6y6vpvxsdwmqmfbkqkwvxc0pz2dqqc72c6fk9sbsrxxaghd5"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/lzfse/lzfse")
+    (synopsis "LZFSE compression library and command line tool")
+    (description "This is a reference C implementation of the LZFSE compressor
+introduced in the Compression library with OS X 10.11 and iOS 9.  LZFSE is a
+Lempel-Ziv style data compression algorithm using Finite State Entropy coding.
+It targets similar compression rates at higher compression and decompression
+speed compared to deflate using zlib")
+    (license license:bsd-3)))
+
 (define-public fcrackzip
   (package
     (name "fcrackzip")
-- 
2.38.1