diff mbox series

[bug#59102,2/2] gnu: Add mogan.

Message ID 86leo2t0ee.fsf@163.com
State New
Headers show
Series None | expand

Commit Message

Zhu Zihao Nov. 23, 2022, 10:42 a.m. UTC
Sorry for the late reply! I missed this mail in my mailbox :( 


Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Unlike TeXmacs, Mogan ships with tests. Could you also run them?

The "tests" folder in mogan is inherited from TeXmacs, I think it's OK
to not run them if we don't run the test of TeXmacs. 

>
>> +    (synopsis "Structural editor delivered by Xmacs Labs")
>
> I don't think the ads is warranted here. Maybe "Scientific text editor"
> is better.
>
>> +    (description
>> +     "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
>> +make everyone to enjoy it fluently and develop new feature for everyone to learn
>> +and create science and technology.")
>
> This description is not very descriptive. I don't have any good idea,
> the repository is not very helpful for that matter. At a minimum,
> I suggest to remove "created by Xmacs Labs" and separate sentences with
> two spaces. The second should also be replaced.
>
>> +    (home-page "https://gitee.com/XmacsLabs/mogan")))
>
> Could you move home-page above synopsis?

fixed in new patch.

I also make Mogan use qt-build-system because Mogan cannot find the
breeze icon without XDG environment variables wrapping.

Comments

Nicolas Goaziou Nov. 26, 2022, 11:03 a.m. UTC | #1
Hello,

Zhu Zihao <all_but_last@163.com> writes:

> Sorry for the late reply! I missed this mail in my mailbox :(

No problem.

> The "tests" folder in mogan is inherited from TeXmacs, I think it's OK
> to not run them if we don't run the test of TeXmacs.

Fair enough.

> fixed in new patch.
>
> I also make Mogan use qt-build-system because Mogan cannot find the
> breeze icon without XDG environment variables wrapping.

OK. Applied. Thank you.

Regards,
diff mbox series

Patch

From c7d14125e93c497a15c27fb4ac90e1d33efc698c Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 14 May 2022 22:19:06 +0800
Subject: [PATCH] gnu: Add mogan.

* gnu/packages/text-editors.scm (mogan): New variable.
---
 gnu/packages/text-editors.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index ed77113726..57341cd198 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -49,6 +49,7 @@  (define-module (gnu packages text-editors)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
   #:use-module (gnu packages aspell)
@@ -59,6 +60,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages code)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages crates-io)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
@@ -895,6 +897,39 @@  (define-public texmacs
     (license license:gpl3+)
     (home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
 
+(define-public mogan
+  (package
+    (inherit texmacs)
+    (name "mogan")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/XmacsLabs/mogan")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "04wz6xmimjv2l6baxgzm8vyq5grg102m3l4wq8i6bglv529yp4ff"))))
+    (build-system qt-build-system)
+    (inputs
+     (modify-inputs (package-inputs texmacs)
+       ;; Replaced by S7 scheme
+       ;; TODO: Maybe unbundle S7
+       (delete "guile")
+       (prepend curl)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments texmacs)
+       ((#:phases orig)
+        #~(modify-phases #$orig
+            ;; The non-deterministic compression issue is solved in Mogan.
+            (delete 'gzip-flags)))))
+    (home-page "https://github.com/XmacsLabs/mogan")
+    (synopsis "Scientific structural text editor")
+    (description
+     "Mogan is a scientific structural text editor, a fork of GNU TeXmacs.")
+    (license license:gpl3+)))
+
 (define-public textpieces
   (package
     (name "textpieces")
-- 
2.38.1