diff mbox

[bug#50117,0/1] go-github-com-aswinkarthik-csvdiff package updates

Message ID 868rwo44a2.fsf@bonfacemunyoki.com
State Accepted
Headers show

Commit Message

Munyoki Kilyungi Dec. 13, 2021, 8:51 p.m. UTC
Arun Isaac <arunisaac@systemreboot.net> anaandika:

> Hi Bonface,
>
>> Hi all!  Find below updated patches from a review from a while back.  @Arun, I
>> have moved csvdiff to textutils(it makes more semantic sense).
>
> Sounds good.
>
>> I see no need of defining it as a deprecated-package since there's no
>> package dependent on it ATM.
>
> Users might have installed csvdiff into their profiles. So, I think we
> still need to define a deprecated-package. Could you send an updated
> patchset?

Yup.  This makes sense.  Find attached a new patch
that adds an alias for the deprecated package.
Let me know if this is okay :)

Comments

Arun Isaac Dec. 20, 2021, 5:35 a.m. UTC | #1
Hi Bonface,

I have applied the patch on master with a few changes. Most
significantly, I moved the deprecated alias from
gnu/packages/textutils.scm to gnu/packages/golang.scm since golang.scm
is where the original package was.

Thanks,
Arun
Munyoki Kilyungi Dec. 21, 2021, 12:29 p.m. UTC | #2
Arun Isaac <arunisaac@systemreboot.net> anaandika:

> Hi Bonface,
>
> I have applied the patch on master with a few changes. Most
> significantly, I moved the deprecated alias from
> gnu/packages/textutils.scm to gnu/packages/golang.scm since golang.scm
> is where the original package was.

Thanks!
diff mbox

Patch

From 6767f1f8ffdbaa4c47b8fdd5778fbf570f4118d8 Mon Sep 17 00:00:00 2001
From: BonfaceKilz <me@bonfacemunyoki.com>
Date: Mon, 13 Dec 2021 23:42:56 +0300
Subject: [PATCH] gnu: Move csvdiff to (gnu packages textutils).

See <http://issues.guix.gnu.org/50117>.

* gnu/packages/golang.scm (go-github-com-aswinkarthik-csvdiff): Move from here
* gnu/packages/textutils (csvdiff): to here.
(go-github-com-aswinkarthik-csvdiff): Add deprecated alias for moved package.
---
 gnu/packages/golang.scm    | 44 ---------------------------------
 gnu/packages/textutils.scm | 50 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 50 insertions(+), 44 deletions(-)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70731e2720..848f20fa1d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8754,50 +8754,6 @@  zero round-trip encryption, and other advanced features.")
 non-cryptographic hash algorithm, working at speeds close to RAM limits.")
     (license license:asl2.0)))
 
-(define-public go-github-com-aswinkarthik-csvdiff
-  (package
-    (name "go-github-com-aswinkarthik-csvdiff")
-    (version "1.4.0")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/aswinkarthik/csvdiff")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "0cd1ikxsypjqisfnmr7zix3g7x8p892w77086465chyd39gpk97b"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/aswinkarthik/csvdiff"))
-    (propagated-inputs
-     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
-       ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
-       ("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)
-       ("go-github-com-spf13-afero" ,go-github-com-spf13-afero)
-       ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
-       ("go-github-com-mattn-go-colorable" ,go-github-com-mattn-go-colorable)
-       ("go-github-com-fatih-color" ,go-github-com-fatih-color)
-       ("go-github-com-cespare-xxhash" ,go-github-com-cespare-xxhash)
-       ("go-github-com-oneofone-xxhash" ,go-github-com-oneofone-xxhash)))
-    (home-page "https://github.com/aswinkarthik/csvdiff")
-    (synopsis "Fast diff tool for comparing CSV files")
-    (description "@code{csvdiff} is a diff tool to compute changes between two
-CSV files.  It can compare CSV files with a million records in under 2
-seconds.  It is specifically suited for comparing CSV files dumped from
-database tables.  GNU Diff is orders of magnitude faster for comparing line by
-line.  @code{csvdiff} supports
-
-@itemize
-@item Selective comparison of fields in a row
-@item Specifying group of columns as primary-key to uniquely identify a row
-@item Ignoring columns
-@item Several output formats including colored git style output or
-JSON for post-processing
-@end itemize")
-    (license license:expat)))
-
 (define-public go-gopkg-in-djherbis-times-v1
   (package
     (name "go-gopkg-in-djherbis-times-v1")
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 7e7293ac16..c3baeeaa0b 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -64,6 +65,7 @@ 
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages syncthing)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages slang)
@@ -1347,3 +1349,51 @@  languages such as HTML, Markdown, Asciidoc, and reStructuredText.  The community
 around it also has a list of style guides implemented with Vale in
 @url{https://github.com/errata-ai/styles, their styles repo}.")
     (license license:expat)))
+
+(define-public csvdiff
+  (package
+    (name "csvdiff")
+    (version "1.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aswinkarthik/csvdiff")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0cd1ikxsypjqisfnmr7zix3g7x8p892w77086465chyd39gpk97b"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/aswinkarthik/csvdiff"))
+    (propagated-inputs
+     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+       ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+       ("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)
+       ("go-github-com-spf13-afero" ,go-github-com-spf13-afero)
+       ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+       ("go-github-com-mattn-go-colorable" ,go-github-com-mattn-go-colorable)
+       ("go-github-com-fatih-color" ,go-github-com-fatih-color)
+       ("go-github-com-cespare-xxhash" ,go-github-com-cespare-xxhash)
+       ("go-github-com-oneofone-xxhash" ,go-github-com-oneofone-xxhash)))
+    (home-page "https://github.com/aswinkarthik/csvdiff")
+    (synopsis "Fast diff tool for comparing CSV files")
+    (description "@code{csvdiff} is a diff tool to compute changes between two
+CSV files.  It can compare CSV files with a million records in under 2
+seconds.  It is specifically suited for comparing CSV files dumped from
+database tables.  GNU Diff is orders of magnitude faster for comparing line by
+line.  @code{csvdiff} supports
+
+@itemize
+@item Selective comparison of fields in a row
+@item Specifying group of columns as primary-key to uniquely identify a row
+@item Ignoring columns
+@item Several output formats including colored git style output or
+JSON for post-processing
+@end itemize")
+    (license license:expat)))
+
+(define-public go-github-com-aswinkarthik-csvdiff
+  (deprecated-package "go-github-com-aswinkarthik-csvdiff" csvdiff))
+
-- 
2.31.1