diff mbox series

[bug#67019,v2,08/16] gnu: Add node-vlq.

Message ID 7f4e71aad9adc111dd5ff673d707ef9e3db0d7e0.1700161584.git.philip@philipmcgrath.com
State New
Headers show
Series gnu: Add KaTeX, lessc, and flow-remove-types. | expand

Commit Message

Philip McGrath Nov. 16, 2023, 7:15 p.m. UTC
* gnu/packages/node-xyz.scm (node-vlq): New variable.
---
 gnu/packages/node-xyz.scm | 58 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index ee96dee767..adbac8a6cd 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1793,3 +1793,61 @@  (define-public node-copy-anything
 face of complications like special objects, symbols, and non-enumerable
 properties.")
     (license license:expat)))
+
+(define-public node-vlq
+  (package
+    (name "node-vlq")
+    (version "0.2.3") ; last version accepted by flow-remove-types ("^0.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Rich-Harris/vlq")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1vdrarssrwxpcngyfx050ba0gnfinzi5jn3xs4w9rnjvxngx6m8f"))
+       (snippet
+        #~(delete-file "dist/vlq.js"))
+       (file-name (git-file-name name version))))
+    (build-system node-build-system)
+    (native-inputs (list esbuild))
+    (arguments
+     (list
+      #:modules
+      `((guix build node-build-system)
+        (ice-9 match)
+        (guix build utils))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'patch-dependencies 'delete-dependencies
+            (lambda args
+              (delete-dependencies
+               '("eslint"
+                 "rollup"))))
+          (add-after 'delete-dependencies 'patch-build-script
+            (lambda args
+              (define new-build-script
+                "esbuild --bundle --platform=node --outdir=dist src/vlq.js")
+              (with-atomic-json-file-replacement "package.json"
+                (lambda (js)
+                  (match js
+                    (('@ . alist)
+                     (cons '@
+                      (map (match-lambda
+                             (("scripts" @ . alist)
+                              `("scripts" @ ,@(map (match-lambda
+                                                     (("build" . _)
+                                                      (cons "build"
+                                                            new-build-script))
+                                                     (other
+                                                      other))
+                                                   alist)))
+                             (other
+                              other))
+                           alist)))))))))))
+    (home-page "https://github.com/Rich-Harris/vlq")
+    (synopsis "JavaScript library for @acronym{VLQ} encoding and decoding")
+    (description "This package provides a JavaScript library for converting
+integers to and from Base64-encoded @acronym{VLQ, variable-length quantity}
+strings.")
+    (license license:expat)))