diff mbox series

[bug#67019,v2,14/16] gnu: Add mftrace.

Message ID 4b3be6a948d9e6da5dd729caaaeff9c5fef06783.1700161584.git.philip@philipmcgrath.com
State New
Headers show
Series gnu: Add KaTeX, lessc, and flow-remove-types. | expand

Commit Message

Philip McGrath Nov. 16, 2023, 7:15 p.m. UTC
* gnu/packages/fontutils.scm (mftrace): New variable.
---
 gnu/packages/fontutils.scm | 45 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 5bfdea1b27..6bab6ab7df 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1182,6 +1182,51 @@  (define-public ttf2pt1
     (home-page "https://ttf2pt1.sourceforge.net/")
     (license license:bsd-3)))
 
+(define-public mftrace
+  (let ((commit "3b4bc2e5b8a4ae6f9c776593961b38389e62a484")
+        ;; see https://github.com/hanwen/mftrace/pull/12
+        (revision "0"))
+    (package
+      (name "mftrace")
+      (version (git-version "1.2.20" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/hanwen/mftrace")
+               (commit commit)))
+         (sha256
+          (base32 "01cg6z1z69za07wrvx1y5dnfagx4di2a9qnx25f97l6843x03s36"))
+         (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (native-inputs (list autoconf
+                           ;; for tests:
+                           (texlive-updmap.cfg
+                            (list texlive-cm))))
+      (propagated-inputs (list potrace lcdf-typetools))
+      (arguments
+       (list
+        ;; setting CC is needed for implicit rule
+        #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+        #:test-target "test"
+        #:phases
+        #~(modify-phases %standard-phases
+            (replace 'bootstrap
+              (lambda args
+                (invoke "autoconf"))))))
+      (home-page "https://lilypond.org/mftrace/")
+      (synopsis "Scalable PostScript fonts for MetaFont")
+      (description "This package provides @command{mftrace}, a small Python
+program that lets you trace a TeX bitmap font into a PFA or PFB font (a
+PostScript Type 1 Scalable Font) or a @acronym{TTF,TrueType Font}.
+
+Scalable fonts offer many advantages over bitmaps, as they allow documents to
+render correctly at many printer resolutions.  Moreover, Ghostscript can
+generate much better PDFs if given scalable PostScript fonts.
+
+Versions of this program prior to 1.0.5 were called @command{pktrace}.")
+      (license license:gpl2+))))
+
 (define-public woff2
   (package
     (name "woff2")