diff mbox series

[bug#68115,08/18] gnu: Add rust-etcetera-0.8.

Message ID 7dc2604501d6ae13120a684bfa41d4fda10fc889.1703894625.git.jaeme@runbox.com
State New
Headers show
Series rust-apps: bat: Update to 0.24 | expand

Commit Message

Jaeme Sifat Dec. 30, 2023, 12:40 a.m. UTC
* gnu/packages/crates-io.scm (rust-etcetera-0.8): New variable.

Change-Id: I363cb9361f6d453f42501d9270114cd0e609c640
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 691df6e5e0..53d06aa5a8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -23774,6 +23774,32 @@  (define-public rust-escargot-0.3
        (("rust-serde" ,rust-serde-1)
         ("rust-serde-json" ,rust-serde-json-1))))))
 
+(define-public rust-etcetera-0.8
+  (package
+    (name "rust-etcetera")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "etcetera" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0hxrsn75dirbjhwgkdkh0pnpqrnq17ypyhjpjaypgax1hd91nv8k"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+                       ("rust-home" ,rust-home-0.5)
+                       ("rust-windows-sys" ,rust-windows-sys-0.48))))
+    (home-page "https://github.com/lunacookies/etcetera")
+    (synopsis
+     "Library for obtaining configuration, data, cache, & other directories")
+    (description
+     "This is a Rust library that allows you to determine the locations of
+configuration, data, cache & other files for your application.  Existing Rust
+libraries generally do not give you a choice in terms of which standards/conventions
+they follow.  Etcetera, on the other hand, gives you the choice.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-ethbloom-0.11
   (package
     (name "rust-ethbloom")