mbox series

[bug#68115,00/18,rust-team] rust-apps: bat: Update to 0.24

Message ID cover.1703894624.git.jaeme@runbox.com
Headers show
Series rust-apps: bat: Update to 0.24 | expand

Message

Jaeme Sifat Dec. 30, 2023, 12:05 a.m. UTC
This patchset updates bat, the cat clone, to 0.24 as well as refactoring any
package definitions along the way.

bat has a really peculiar way to packaging its extra files (completions +
manual). Mainly, this results in bat.1 not having the correct project
exectuable name instead using the placeholder.

If you can find a solution to this, I'll be glad to hear it. Not even nixpkgs
packages the extra files.

Jaeme Sifat (18):
  gnu: Add rust-fancy-regex-0.11.
  gnu: Add rust-syntect-5.
  gnu: Add rust-fsio-0.4.
  gnu: Add rust-run-script-0.10.
  gnu: Add rust-print-bytes-0.7.
  gnu: Add rust-os-str-bytes-6.4.
  gnu: Add rust-nu-ansi-term-0.49.
  gnu: Add rust-etcetera-0.8.
  gnu: Add rust-clircle-0.4.
  gnu: rust-clircle-0.3: Allow building.
  gnu: Add rust-bugreport-0.5.
  gnu: rust-bugreport-0.4: Update to 0.4.1.
  gnu: rust-empfindung-0.2: Update to 0.2.6.
  gnu: Add rust-crc64-2.
  gnu: rust-crc64-1: Allow building.
  gnu: Add rust-termcolor-1.2.
  gnu: rust-ansi-colours-1: Update to 1.2.2.
  gnu: bat: Update to 0.24.0.

 gnu/packages/crates-graphics.scm |  15 +-
 gnu/packages/crates-io.scm       | 328 +++++++++++++++++++++++++++----
 gnu/packages/rust-apps.scm       |  85 +++++---
 gnu/packages/shells.scm          |  36 +++-
 4 files changed, 385 insertions(+), 79 deletions(-)


base-commit: 5844d18a8905ee3f62ccefe084dce4de61288fbf
prerequisite-patch-id: 26f99ffe625016ac09bcce1a95d62c271ea1b23b
prerequisite-patch-id: 117c5537eb0db1e776e5d0ca62a931db582926db
prerequisite-patch-id: f011e6b1a58ebd7efbd6809317f46e830a45175b
prerequisite-patch-id: c0855af5363dc7d96f58687ac9fca5bb2caeec28
--
2.41.0

Comments

Jaeme Sifat Dec. 30, 2023, 9:36 p.m. UTC | #1
The issue with the manual could most likely be solved with the 
`substitute` procedure by replacing the instances of 
`{{PROJECT_EXECUTABLE}}` and `{{PROJECT_EXECUTABLE_UPPERCASE}}` with 
`bat` and `BAT` respectively.
Efraim Flashner Jan. 2, 2024, 9:39 a.m. UTC | #2
On Fri, Dec 29, 2023 at 07:05:03PM -0500, Jaeme Sifat wrote:
> This patchset updates bat, the cat clone, to 0.24 as well as refactoring any
> package definitions along the way.
> 
> bat has a really peculiar way to packaging its extra files (completions +
> manual). Mainly, this results in bat.1 not having the correct project
> exectuable name instead using the placeholder.
> 
> If you can find a solution to this, I'll be glad to hear it. Not even nixpkgs
> packages the extra files.

My secret to finding this is to check the .github folder to see what
they use for CI. Between that and reading the build.rs I learned that if
BAT_ASSETS_GEN_DIR or OUT_DIR is set then the generated assets will go
in that directory. I adjusted the custom phase(s) accordingly to
generate them and then install those files.

I really appreciated your attention to the descriptions for the
packages, some of them were much much better than what upstream had.

Patches added to the rust-team branch!