diff mbox series

[bug#66717,47/64] gnu: Add rust-claxon-0.4.

Message ID 7b52acc7ba26ab4c9ee57f3c680674b774c7a7c4.1698099451.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-playback-0.4 | expand

Commit Message

Steve George Oct. 23, 2023, 10:21 p.m. UTC
* gnu/packages/crates-io.scm (rust-claxon-0.4): New variable.
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b0e02f947a..133c91bc2a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12641,6 +12641,31 @@  (define-public rust-clang-sys-1
     (description "This package provides Rust bindings for libclang.")
     (license license:asl2.0)))
 
+(define-public rust-claxon-0.4
+  (package
+    (name "rust-claxon")
+    (version "0.4.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "claxon" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1206mxvw833ysg10029apcsjjwly8zmsvksgza5cm7ma4ikzbysb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t ;mp4parse has to be changed to build
+       #:cargo-development-inputs
+        (("rust-hound" ,rust-hound-3)
+         ("rust-mp4parse" ,rust-mp4parse-0.8)
+         ("rust-ogg" ,rust-ogg-0.5)
+         ("rust-time" ,rust-time-0.1)
+         ("rust-walkdir" ,rust-walkdir-1))))
+    (home-page "https://github.com/ruuda/claxon#readme")
+    (synopsis "A FLAC decoding library")
+    (description "This package provides a FLAC decoding library.")
+    (license license:asl2.0)))
+
 (define-public rust-cipher-0.4
   (package
     (name "rust-cipher")