diff mbox series

[bug#66717,21/64] gnu: Add rust-hound-3.

Message ID 17b6ba63474dd57599fcdc26e682309de52bd760.1698099450.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-playback-0.4 | expand

Commit Message

Steve George Oct. 23, 2023, 10:21 p.m. UTC
* gnu/packages/crates-io.scm (rust-hound-3): New variable.
---
 gnu/packages/crates-io.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 792ed5262a..4d8514fa67 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31808,6 +31808,25 @@  (define-public rust-hostname-0.1
        (("rust-libc" ,rust-libc-0.2)
         ("rust-winutil" ,rust-winutil-0.1))))))
 
+(define-public rust-hound-3
+  (package
+    (name "rust-hound")
+    (version "3.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "hound" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1cadkxzdsb3bxwzri6r6l78a1jy9j0jxrfwmh34gjadvbnyws4sd"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #t)) ; building source opens up a big dependency tree
+    (home-page "https://github.com/ruuda/hound")
+    (synopsis "A wav encoding and decoding library")
+    (description "This package provides a wav encoding and decoding library.")
+    (license license:asl2.0)))
+
 (define-public rust-html5ever-0.26
   (package
     (name "rust-html5ever")