diff mbox series

[bug#65118,v2,7/9] gnu: Add go-github-com-nsqio-go-diskqueue.

Message ID 7b27ab3342013b58de3dcc9e77959b397078d04d.1693597912.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: Add NSQ. | expand

Commit Message

Sharlatan Hellseher Sept. 1, 2023, 7:58 p.m. UTC
* gnu/packages/golang.scm (go-github-com-nsqio-go-diskqueue): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 62505ff732..756700ef97 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3183,6 +3183,29 @@  (define-public go-github-com-nathan-osman-go-sunrise
 sunset times from geographical coordinates and a date.")
       (license license:expat))))
 
+(define-public go-github-com-nsqio-go-diskqueue
+  (package
+    (name "go-github-com-nsqio-go-diskqueue")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nsqio/go-diskqueue")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hp66hkmfn0nyf3c53a40f94ah11a9rj01r5zp3jph9p54j8rany"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/nsqio/go-diskqueue"))
+    (home-page "https://github.com/nsqio/go-diskqueue")
+    (synopsis "Go package providing a filesystem-backed FIFO queue")
+    (description
+     "The @code{diskqueue} Go package provides a filesystem-backed FIFO
+queue.")
+    (license license:expat)))
+
 (define-public go-github-com-hebcal-gematriya
   (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
         (revision "0"))