diff mbox series

[bug#65118,v2,8/9] gnu: Add go-github-com-nsqio-go-nsq.

Message ID 5ff30e3de2f45e1678d6283a3712193a975e5f4b.1693597912.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: Add NSQ. | expand

Commit Message

Sharlatan Hellseher Sept. 1, 2023, 7:58 p.m. UTC
* gnu/packages/golang.scm (go-github-com-nsqio-go-nsq): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 756700ef97..1f70741f5b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3206,6 +3206,32 @@  (define-public go-github-com-nsqio-go-diskqueue
 queue.")
     (license license:expat)))
 
+(define-public go-github-com-nsqio-go-nsq
+  (package
+    (name "go-github-com-nsqio-go-nsq")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nsqio/go-nsq")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1h9z3z225sdgg7fl3l7x11xn5ch6lm5flgmcj046cdp453qj2qhf"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:tests? #f ;It requires local network setup.
+           #:import-path "github.com/nsqio/go-nsq"))
+    (propagated-inputs (list go-github-com-golang-snappy))
+    (home-page "https://github.com/nsqio/go-nsq")
+    (synopsis "Golang package of high-level Consumer and Produce for NSQ")
+    (description
+     "The @code{nsq} Go module provides a high-level consumer and producer
+types as well as low-level functions to communicate over the NSQ protocol
+@url{https://nsq.io/}.")
+    (license license:expat)))
+
 (define-public go-github-com-hebcal-gematriya
   (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
         (revision "0"))