diff mbox series

[bug#70536,2/2] v2 gnu: Add r-seraster.

Message ID 79ede4754c5753d845573ed8b4c09e8f44ce00c1.1713882185.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series None | expand

Commit Message

Mădălin Ionel Patrașcu April 23, 2024, 2:23 p.m. UTC
* gnu/packages/bioinformatics.scm (r-seraster): New variable.

Change-Id: I9f9fd24a9aa563f7c74154e613b85dee46bdcf79
---
 gnu/packages/bioinformatics.scm | 39 +++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)


base-commit: 2d19e505f6f9f82aebc9ba8c74ba223818acd9bc
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa6bce5591..514d01c87f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13159,6 +13159,45 @@  (define-public r-seqgl
 factors bound at the specific regions.")
     (license license:gpl2+)))
 
+(define-public r-seraster
+  ;; There are no tags or releases.
+  (let ((commit "4fdc1ffe5d3feb65de9880329d221cf276b393a1")
+        (revision "1"))
+    (package
+      (name "r-seraster")
+      (version (git-version "0.99.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/JEFworks-Lab/SEraster")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0y33lk8q0h9nfzmf7slxxvw3l0djassp4l63nsjpm3p6z4pah5s4"))))
+      (properties `((upstream-name . "SEraster")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-biocparallel
+                               r-ggplot2
+                               r-matrix
+                               r-rearrr
+                               r-sf
+                               r-spatialexperiment
+                               r-summarizedexperiment))
+      (home-page "https://github.com/JEFworks-Lab/SEraster")
+      (synopsis
+       "Rasterization framework for scalable spatial omics data analysis")
+      (description
+       "This package is a rasterization preprocessing framework that aggregates
+cellular information into spatial pixels to reduce resource requirements for
+spatial omics data analysis.  SEraster reduces the number of points in spatial
+omics datasets for downstream analysis through a process of rasterization where
+single cells gene expression or cell-type labels are aggregated into equally
+sized pixels based on a user-defined resolution.  SEraster can be incorporated
+with other packages to conduct downstream analyses for spatial omics datasets,
+such as detecting spatially variable genes.")
+      (license license:gpl3))))
+
 (define-public emboss
   (package
     (name "emboss")