diff mbox series

[bug#65535,4/5] gnu: Add r-ggstatsplot.

Message ID 76eab1b66c7e36ced93f1fb109f7998903cd2f17.1692968852.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** Patch for r-ggstatsplot plus its dependencies *** | expand

Commit Message

nafkhamdc Aug. 25, 2023, 1:12 p.m. UTC
* gnu/packages/cran.scm (r-ggstatsplot): New variable.
---
 gnu/packages/cran.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d9618a9d14..d928ac1030 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -744,6 +744,49 @@  (define-public r-ggfittext
      "Ggfittext is a ggplot2 extension for fitting text into boxes.")
     (license license:gpl2)))
 
+(define-public r-ggstatsplot
+  (package
+    (name "r-ggstatsplot")
+    (version "0.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "ggstatsplot" version))
+              (sha256
+               (base32
+                "17jxvzr4dlvsakrsvblxngg60jxh0c1a0i8phqqg63nbf79ng2lk"))))
+    (properties `((upstream-name . "ggstatsplot")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-correlation
+                             r-datawizard
+                             r-dplyr
+                             r-ggcorrplot
+                             r-ggplot2
+                             r-ggrepel
+                             r-ggside
+                             r-ggsignif
+                             r-glue
+                             r-insight
+                             r-paletteer
+                             r-parameters
+                             r-patchwork
+                             r-performance
+                             r-purrr
+                             r-rlang
+                             r-statsexpressions
+                             r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://indrajeetpatil.github.io/ggstatsplot/")
+    (synopsis "Based plots with statistical details")
+    (description
+     "This package generates graphics with embedded details from statistical tests.
+Statistical tests included in the plots themselves.  It provides an easier
+syntax to generate information-rich plots for statistical analysis of
+continuous or categorical data.  Currently, it supports the most common
+types of statistical approaches and tests: parametric, nonparametric,
+robust, and Bayesian versions of t-test/ANOVA, correlation analyses,
+contingency table analysis, meta-analysis, and regression analyses.")
+    (license license:gpl3)))
+
 (define-public r-glmpca
   (package
     (name "r-glmpca")