diff mbox series

[bug#65535,2/5] gnu: Add r-statsexpressions.

Message ID 61d36d8d9050a9f103785933f74e0eb74d2b999c.1692968852.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** Patch for r-ggstatsplot plus its dependencies *** | expand

Commit Message

nafkhamdc Aug. 25, 2023, 1:12 p.m. UTC
* gnu/packages/cran.scm (r-statsexpressions): New variable.
---
 gnu/packages/cran.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 667decab70..dd90da6826 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8113,6 +8113,50 @@  (define-public r-statip
 @end itemize")
     (license license:gpl3)))
 
+(define-public r-statsexpressions
+  (package
+    (name "r-statsexpressions")
+    (version "1.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "statsExpressions" version))
+              (sha256
+               (base32
+                "1lq4h3a8yr7wnmjkg2rgr8524vdpfacr73pv4wxj44dbg9yh8l3x"))))
+    (properties `((upstream-name . "statsExpressions")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-afex
+                             r-bayesfactor
+                             r-correlation
+                             r-datawizard
+                             r-dplyr
+                             r-effectsize
+                             r-glue
+                             r-insight
+                             r-magrittr
+                             r-parameters
+                             r-performance
+                             r-pmcmrplus
+                             r-purrr
+                             r-rlang
+                             r-tibble
+                             r-tidyr
+                             r-withr
+                             r-wrs2
+                             r-zeallot))
+    (native-inputs (list r-knitr))
+    (home-page "https://indrajeetpatil.github.io/statsExpressions/")
+    (synopsis "Dataframes and expressions with statistical details")
+    (description
+     "Tools for creating detailed dataframes for common statistical approaches and tests.
+These include parametric, nonparametric, robust, and Bayesian t-test,
+one-way ANOVA, correlation analyses, contingency table analyses, and
+meta-analyses.  The functions are pipe-friendly and provide a consistent
+syntax to work with tidy data.  These dataframes additionally contain
+expressions with statistical details, and can be used in graphing packages.
+This package also forms the statistical processing backend for ggstatsplot.")
+    (license license:gpl3)))
+
 (define-public r-stringdist
   (package
     (name "r-stringdist")