diff mbox series

[bug#59607,5/8] gnu: Add python-filterpy.

Message ID 7657246e20fc5dede55b714864d8eae90ec73dfd.camel@gmail.com
State New
Headers show
Series Upscale your anime pictures, now with 99% less malware | expand

Commit Message

Liliana Marie Prikler Nov. 25, 2022, 8:37 p.m. UTC
* gnu/packages/python-science.scm (python-filterpy): New variable.
---
 gnu/packages/python-science.scm | 50 +++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 52fe1460bb..d69e43be4e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -634,6 +634,56 @@  (define-public python-fbpca
 analysis} (PCA), SVD, and eigendecompositions via randomized methods")
     (license license:bsd-3)))
 
+(define-public python-filterpy
+  (package
+    (name "python-filterpy")
+    (version "1.4.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rlabbe/filterpy")
+                    (commit version)))
+              (sha256
+               (base32
+                "1i7v7jfi0ysc2rz9fkxyrmdbh4a1ahcn6vgjajj0zs6wla3jnmxm"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'mark-failing-tests
+                 (lambda _
+                   (substitute* "filterpy/kalman/tests/test_kf.py"
+                     (("from __future__ import .*" all)
+                      (string-append all "\nimport pytest\n"))
+                     (("def test_(noisy_1d|steadystate)" all)
+                      (string-append "@pytest.mark.xfail()\n"
+                                     all)))
+                   (substitute* "filterpy/kalman/tests/test_fm.py"
+                     (("from pytest import .*" all)
+                      (string-append all "\nimport pytest\n"))
+                     (("def test_noisy_1d" all)
+                      (string-append "@pytest.mark.xfail()\n"
+                                     all)))
+                   (substitute* "filterpy/stats/tests/test_stats.py"
+                     (("from __future__ import .*" all)
+                      (string-append all "\nimport pytest\n"))
+                     (("def test_mahalanobis" all)
+                      (string-append "@pytest.mark.xfail()\n"
+                                     all)))))
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "pytest" "-vv")))))))
+    (propagated-inputs (list python-numpy python-scipy))
+    (native-inputs (list python-pytest))
+    (home-page "https://filterpy.readthedocs.io/")
+    (synopsis "Kalman and Bayesian filters")
+    (description
+     "This package provides implementations of various filters, such as the
+Kalman filter, its extended and unscented variants, recursive least squares,
+and others.")
+    (license license:expat)))
+
 (define-public python-geosketch
   (package
     (name "python-geosketch")