diff mbox series

[bug#59607,3/8] gnu: Add python-addict.

Message ID 06c7b8e263ad8d7191cadc00d1704e07ff7f5664.camel@gmail.com
State New
Headers show
Series Upscale your anime pictures, now with 99% less malware | expand

Commit Message

Liliana Marie Prikler Nov. 20, 2022, 9:10 a.m. UTC
* gnu/packages/python-xyz.scm (python-addict): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7fefbc5bff..d0591b4614 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -581,6 +581,24 @@  (define-public python-dotmap
 dictionary, can be convert to a dictionary, and is ordered by insertion.")
     (license license:expat)))
 
+(define-public python-addict
+  (package
+    (name "python-addict")
+    (version "2.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "addict" version))
+              (sha256
+               (base32
+                "1574sicy5ydx9pvva3lbx8qp56z9jbdwbj26aqgjhyh61q723cmk"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/mewwts/addict")
+    (synopsis "Dictionaries with items as attributes")
+    (description
+     "This package provides a dictionary type, whose values are both gettable
+and settable using attributes, in addition to standard item-syntax.")
+    (license license:expat)))
+
 (define-public python-twodict
   (package
     (name "python-twodict")