diff mbox series

[bug#69023,1/5] gnu: bqn: Add singeli.

Message ID 75533bd75ddccc62b5041e1532d6161f074ef93a.1707607099.git.aecepoglu@fastmail.fm
State New
Headers show
Series gnu: package: Update cbqn. | expand

Commit Message

aecepoglu Feb. 10, 2024, 11:28 p.m. UTC
Newer versions of BQN use Singeli

* gnu/packages/bqn.scm: Add singeli

Change-Id: I5a2ce84a2b96cdad0617af46978f44ef1a86047f
---
 gnu/packages/bqn.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Liliana Marie Prikler April 19, 2024, 6:44 p.m. UTC | #1
Am Samstag, dem 10.02.2024 um 23:28 +0000 schrieb aecepoglu:
> Newer versions of BQN use Singeli
This comment is kinda gratuitous, but if you need it, please make it a
full sentence.

> * gnu/packages/bqn.scm: Add singeli
Missing final dot.

> Change-Id: I5a2ce84a2b96cdad0617af46978f44ef1a86047f
> ---
>  gnu/packages/bqn.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
> 
> diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
> index 4d03385d21..acac2d45cc 100644
> --- a/gnu/packages/bqn.scm
> +++ b/gnu/packages/bqn.scm
> @@ -34,6 +34,32 @@ (define-module (gnu packages bqn)
>    #:use-module (gnu packages java)
>    #:use-module (gnu packages compression))
>  
> +(define-public singeli
> +  (let ((commit "5f9cbd46c265491ff167a5d9377d1462539dbdd8")
> +        (revision "1"))
> +    (package
> +      (name "singeli")
> +      (version (git-version "0.1.1" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/mlochbaum/Singeli.git")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "13mfxkb29n4phpqxiwfcd43mcg8773n03nml8d9rhbdb6s5jrixb"))))
> +      (build-system copy-build-system)
> +      (arguments
> +       '(#:install-plan '(("." "lib"))))
This… looks weird.  Particularly given that the layout of Singeli looks
like a source tree with all kinds of things.
> +      (synopsis "Language to generate performant C codes with")
I'd prefer "Domain-specific language for high-performance algorithms".
WDYT?
> +      (description
> +       "Singeli is a domain-specific language for building high-
> performance
> +algorithms with abstractions over code that corresponds to
> individual instructions.
> +It's implemented in BQN, with a frontend that emits IR and a backend
> that converts it to C.")
> +      (home-page "https://github.com/mlochbaum/Singeli")
> +      (license license:isc))))
> +
>  (define-public dbqn
>    (let ((commit "88f2b43966a75cc2c382421218eb30003bb16f4a")
>          (revision "1"))

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index 4d03385d21..acac2d45cc 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -34,6 +34,32 @@  (define-module (gnu packages bqn)
   #:use-module (gnu packages java)
   #:use-module (gnu packages compression))
 
+(define-public singeli
+  (let ((commit "5f9cbd46c265491ff167a5d9377d1462539dbdd8")
+        (revision "1"))
+    (package
+      (name "singeli")
+      (version (git-version "0.1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mlochbaum/Singeli.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13mfxkb29n4phpqxiwfcd43mcg8773n03nml8d9rhbdb6s5jrixb"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("." "lib"))))
+      (synopsis "Language to generate performant C codes with")
+      (description
+       "Singeli is a domain-specific language for building high-performance
+algorithms with abstractions over code that corresponds to individual instructions.
+It's implemented in BQN, with a frontend that emits IR and a backend that converts it to C.")
+      (home-page "https://github.com/mlochbaum/Singeli")
+      (license license:isc))))
+
 (define-public dbqn
   (let ((commit "88f2b43966a75cc2c382421218eb30003bb16f4a")
         (revision "1"))