diff mbox series

[bug#69023,3/5] gnu: bqn: Update bqn-sources.

Message ID 377d37ff0dd5b4611eab77533d3417735c10264c.1707607099.git.aecepoglu@fastmail.fm
State New
Headers show
Series gnu: package: Update cbqn. | expand

Commit Message

aecepoglu Feb. 10, 2024, 11:28 p.m. UTC
* gnu/packages/bqn.scm (bqn-sources): Update bqn-sources version.

Change-Id: Ia17dfbc3d6d73fdf3203c99a229eccc6634eca2a
---
 gnu/packages/bqn.scm | 21 ++++++++++-----------
 1 file changed, 10 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index b4d141fc7a..9623fd5b57 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -135,17 +135,16 @@  (define-public dbqn
 
 (define bqn-sources
   ;; Aside from dbqn above, the main bqn repository is used by other
-  ;; implementations as a "known good" set of sources. CBQN uses dbqn to
-  ;; generate an intermediate bytecode for its own compilation.
-    (let ((commit "71ce36141aaacfa714edca2e408ca522a3bc5554"))
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-              (url "https://github.com/mlochbaum/BQN")
-              (commit commit)))
-        (file-name (git-file-name "bqn-sources" commit))
-        (sha256
-         (base32 "060a3r5m7hynzxj4iz1av2kj5jf8w3j8yswzzx9wkx31rdrsiv2c")))))
+  ;; implementations as a "known good" set of sources.
+  ;; CBQN initially uses dbqn to bootstrap itself.
+  ;; We use cbqn-bootstrap to build BQN for the end-users
+  (let ((commit "6f651be3e09f0628c7d47ddb7ce819a1755529ca"))
+    (origin
+      (method git-fetch)
+      (uri (git-reference (url "https://github.com/mlochbaum/BQN")
+                          (commit commit)))
+      (file-name (git-file-name "bqn-sources" commit))
+      (sha256 (base32 "0jhrazwp4s1a0pzrzyxi7szpchp4avqsvpmslfsgk3c88wf57q6b")))))
 
 (define cbqn-bootstrap
   (let* ((revision "2")