diff mbox series

[bug#39077,2/4] gnu: Add go-github-com-rifflock-lfshook.

Message ID 751e0df2-54e0-493d-92c0-18081aa56613@www.fastmail.com
State Accepted
Headers show
Series gnu: Add browserpass-native. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alex Griffin Jan. 10, 2020, 10:33 p.m. UTC
attached
diff mbox series

Patch

From 31bce6a641343d809a84678fff67259936a9b56c Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Fri, 10 Jan 2020 13:32:32 -0600
Subject: [PATCH 2/4] gnu: Add go-github-com-rifflock-lfshook.

* gnu/packages/golang.scm (go-github-com-rifflock-lfshook): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1b7f0f3487..9dd9b37cf0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1184,6 +1184,31 @@  GNU extensions} to the POSIX recommendations for command-line options.")
 compatible with the standard library logger.")
     (license license:expat)))
 
+(define-public go-github-com-rifflock-lfshook
+  (package
+    (name "go-github-com-rifflock-lfshook")
+    (version "2.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rifflock/lfshook.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wxqjcjfg8c0klmdgmbw3ckagby3wg9rkga9ihd4fsf05x5scxrc"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/rifflock/lfshook"))
+    (propagated-inputs
+     `(("go-github-com-sirupsen-logrus" ,go-github-com-sirupsen-logrus)))
+    (home-page "https://github.com/rifflock/lfshook")
+    (synopsis "Local File System hook for Logrus logger")
+    (description "This package provides a hook for Logrus to write directly to
+a file on the filesystem.  The log levels are dynamic at instantiation of the
+hook, so it is capable of logging at some or all levels.")
+    (license license:expat)))
+
 (define-public go-github-com-kardianos-osext
   (let ((commit "ae77be60afb1dcacde03767a8c37337fad28ac14")
         (revision "1"))
-- 
2.24.1