diff mbox series

[bug#39077,3/4] gnu: Add go-github-com-mattn-go-zglob.

Message ID 26154f24-ab7f-4a6c-b021-b97f9cb559bd@www.fastmail.com
State Accepted
Headers show
Series gnu: Add browserpass-native. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alex Griffin Jan. 10, 2020, 10:34 p.m. UTC
attached
diff mbox series

Patch

From 9ff783804d62248eb0efcfb69588b4e3cf49e2e1 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Fri, 10 Jan 2020 13:36:57 -0600
Subject: [PATCH 3/4] gnu: Add go-github-com-mattn-go-zglob.

* gnu/packages/golang.scm (go-github-com-mattn-go-zglob): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9dd9b37cf0..8665a5f26e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3105,3 +3105,25 @@  alternative to @code{reflect.DeepEqual} for comparing whether two values
 are semantically equal in Go (for writing tests).")
     (home-page "https://godoc.org/github.com/google/go-cmp/cmp")
     (license license:asl2.0)))
+
+(define-public go-github-com-mattn-go-zglob
+  (package
+    (name "go-github-com-mattn-go-zglob")
+    (version "0.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mattn/go-zglob.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1sncdyq5fbd42al4amyy91h7vlzm3wm6c9vl8za2pjgfgsd581fz"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/mattn/go-zglob"))
+    (home-page "https://github.com/mattn/go-zglob")
+    (synopsis "Glob library that descends into other directories")
+    (description " A glob library that implements descending into other
+directories.  It is optimized for filewalking. ")
+    (license license:expat)))
-- 
2.24.1