diff mbox series

[bug#60448,4/6] gnu: Add perl-syntax-keyword-try

Message ID 74d03d1618fd7e917cfa635a8001628fa584522a.1672465269.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: po4a: Update to 0.68 | expand

Commit Message

gemmaro Dec. 31, 2022, 2:04 p.m. UTC
This is required by po4a since v0.67.
https://github.com/mquinson/po4a/blob/0ab1670e50f0a72781e3d1de6ab9da0c2d71c646/NEWS#L125
---
 gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1c21f30133..437c02c195 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9996,6 +9996,30 @@  (define-public perl-switch
 statements: @code{switch} and @code{case}.")
     (license (package-license perl))))
 
+(define-public perl-syntax-keyword-try
+  (package
+    (name "perl-syntax-keyword-try")
+    (version "0.27")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/P/PE/PEVANS/Syntax-Keyword-Try-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "08yyfhavmddix35kb7dvvj646symw2vd8l058bajzwiz7q1invi4"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build))
+    (inputs (list perl-xs-parse-keyword))
+    (home-page "https://metacpan.org/pod/Syntax::Keyword::Try")
+    (synopsis "Try/catch/finally syntax for perl")
+    (description
+     "This module provides a syntax plugin that implements
+exception-handling semantics in a form familiar to users of other
+languages, being built on a block labeled with the @code{try} keyword,
+followed by at least one of a @code{catch} or @code{finally} block.")
+    (license (package-license perl))))
+
 (define-public perl-sys-cpu
   (package
     (name "perl-sys-cpu")