diff mbox series

[bug#60448,3/6] gnu: Add perl-text-wrapi18n

Message ID 6af2cbcef0af7c8920350a5aff2da8054c093fa5.1672465269.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: po4a: Update to 0.68 | expand

Commit Message

gemmaro Dec. 31, 2022, 2:04 p.m. UTC
---
 gnu/packages/perl.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 09f5d9e69d..1c21f30133 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -12255,6 +12255,34 @@  (define-public perl-text-soundex
 the National Archives and Records Administration (NARA).")
     (license license:perl-license)))
 
+(define-public perl-text-wrapi18n
+  (package
+    (name "perl-text-wrapi18n")
+    (version "0.06")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/K/KU/KUBOTA/Text-WrapI18N-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "12548qc99ms12yp5j26076p0zazjfv1b618h5k8r5iy2y0brmljb"))))
+    (build-system perl-build-system)
+    (inputs (list perl-text-charwidth))
+    (home-page "https://metacpan.org/pod/Text::WrapI18N")
+    (synopsis "Line wrapping for multibyte, fullwidth, and combining
+characters and so on")
+    (description
+     "This module intends to be a better Text::Wrap module.  This
+module is needed to support multibyte character encodings such as UTF-8,
+EUC-JP, EUC-KR, GB2312, and Big5.  This module also supports characters with
+irregular widths, such as combining characters (which occupy zero columns on
+terminal, like diacritical marks in UTF-8) and fullwidth characters (which
+occupy two columns on terminal, like most of east Asian characters).  Also,
+minimal handling of languages which doesn't use whitespaces between
+words (like Chinese and Japanese) is supported.")
+    (license (package-license perl))))
+
 (define-public perl-regexp-pattern
   (package
     (name "perl-regexp-pattern")