diff mbox series

[bug#62252,11/19] gnu: python-starlette: Update to 0.25.0.

Message ID 7466968dec1d8e1887f5c5fb28a0b319da5a1d77.camel@gmail.com
State New
Headers show
Series Add python-clinguin | expand

Commit Message

Liliana Marie Prikler March 18, 2023, 7:48 a.m. UTC
* gnu/packages/python-web.scm (python-starlette): Update to 0.25.0.
[source]: Switch to git-fetch and git-reference.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-hatchling, python-httpx, python-pytest, and
python-typing-extensions-next.
---
 gnu/packages/python-web.scm | 17 ++++++++++++-----
 1 file changed, 12 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8a73c929a1..2df8fbc523 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8064,14 +8064,17 @@  (define-public python-sendgrid
 (define-public python-starlette
   (package
     (name "python-starlette")
-    (version "0.20.4")
+    (version "0.25.0")
     (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "starlette" version))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/encode/starlette")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "112hmwk4fh4dl21nlr2xd37h43xzxpjxfnic7v7fz3wr5w9g7z22"))))
-    (build-system python-build-system)
+                "1mkkj15lphgycnp51dnrfxbyrx3dicjdcpsqvwc7yw55zyih6h5k"))))
+    (build-system pyproject-build-system)
     (propagated-inputs (list python-anyio
                              python-typing-extensions
                              ;; [all] extra dependencies:
@@ -8080,6 +8083,10 @@  (define-public python-starlette
                              python-multipart
                              python-pyyaml
                              python-requests))
+    (native-inputs (list python-hatchling
+                         python-httpx
+                         python-pytest
+                         python-typing-extensions-next))
     (home-page "https://github.com/encode/starlette")
     (synopsis "Little ASGI library")
     (description