diff mbox series

[bug#62252,09/19] gnu: python-pluggy: Move to (gnu packages python-build).

Message ID 49593cd218f2e5a3b157fb9768804fdc5e6de79c.camel@gmail.com
State New
Headers show
Series Add python-clinguin | expand

Commit Message

Liliana Marie Prikler March 18, 2023, 7:44 a.m. UTC
* gnu/packages/python-xyz.scm (python-pluggy, python-pluggy-next): Move from
here…
* gnu/packages/python-build.scm (python-pluggy, python-pluggy-next): …to here.
Reindent using Emacs.
---
 gnu/packages/python-build.scm | 33 +++++++++++++++++++++++++++++++++
 gnu/packages/python-xyz.scm   | 33 ---------------------------------
 2 files changed, 33 insertions(+), 33 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index a4be4b4991..1281824a97 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -589,3 +589,36 @@  (define-public python-pathspec
 specified patterns.  It is currently limited to wildmatch-style patterns,
 which are used e.g. in .gitignore files.")
     (license license:mpl2.0)))
+
+(define-public python-pluggy
+  (package
+    (name "python-pluggy")
+    (version "0.13.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pluggy" version))
+       (sha256
+        (base32
+         "1c35qyhvy27q9ih9n899f3h4sdnpgq027dbiilly2qb5cvgarchm"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-setuptools-scm))
+    (synopsis "Plugin and hook calling mechanism for Python")
+    (description "Pluggy is an extraction of the plugin manager as used by
+Pytest but stripped of Pytest specific details.")
+    (home-page "https://pypi.org/project/pluggy/")
+    (license license:expat)))
+
+;;; TODO: Make this the default python-pluggy in the next rebuild cycle.
+(define-public python-pluggy-next
+  (package
+    (inherit python-pluggy)
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pluggy" version))
+       (sha256
+        (base32
+         "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b506f4daa9..9c9178f030 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15386,39 +15386,6 @@  (define-public python-rsa
    (home-page "https://stuvel.eu/rsa")
    (license license:asl2.0)))
 
-(define-public python-pluggy
-  (package
-   (name "python-pluggy")
-   (version "0.13.1")
-   (source
-    (origin
-     (method url-fetch)
-     (uri (pypi-uri "pluggy" version))
-     (sha256
-      (base32
-       "1c35qyhvy27q9ih9n899f3h4sdnpgq027dbiilly2qb5cvgarchm"))))
-   (build-system python-build-system)
-   (native-inputs
-    (list python-setuptools-scm))
-   (synopsis "Plugin and hook calling mechanism for Python")
-   (description "Pluggy is an extraction of the plugin manager as used by
-Pytest but stripped of Pytest specific details.")
-   (home-page "https://pypi.org/project/pluggy/")
-   (license license:expat)))
-
-;;; TODO: Make this the default python-pluggy in the next rebuild cycle.
-(define-public python-pluggy-next
-  (package
-   (inherit python-pluggy)
-   (version "1.0.0")
-   (source
-    (origin
-     (method url-fetch)
-     (uri (pypi-uri "pluggy" version))
-     (sha256
-      (base32
-       "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))))
-
 (define-public python-plumbum
   (package
     (name "python-plumbum")