diff mbox series

[bug#45241,2/5] gnu: sdcc: Specify complete set of licenses.

Message ID 72a25776059841e35fda8c4717956098799fc0e4.1607965728.git.simon@simonsouth.net
State Accepted
Headers show
Series gnu: sdcc: Polish up package definition | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Simon South Dec. 14, 2020, 6:06 p.m. UTC
* gnu/packages/embedded.scm (sdcc)[license]: Replace with full list of
licenses used by files in the distribution.
---
 gnu/packages/embedded.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 2d822cecf3..545c512f18 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1511,4 +1511,10 @@  HC08-based (hc08, s08), Zilog Z80-based MCUs (z80, z180, gbz80, Rabbit
 2000/3000, Rabbit 3000A, TLCS-90) and STMicroelectronics STM8.
 Work is in progress on supporting the Microchip PIC16 and PIC18 targets.
 It can be retargeted for other microprocessors.")
-    (license license:gpl2+)))
+    (license (list license:gpl2+
+                   license:gpl3+
+                   license:lgpl2.0+
+                   license:lgpl2.1+
+                   license:lgpl3+
+                   license:public-domain
+                   license:zlib))))