diff mbox series

[bug#46680] gnu: Add midicomp.

Message ID 721dc0ef8b515ad8f62deecb7a8549868183fcff.camel@zrythm.org
State Accepted
Headers show
Series [bug#46680] gnu: Add midicomp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Alexandros Theodotou Feb. 23, 2021, 6:56 p.m. UTC
Hi,

Thanks for the feedback, I updated the patch (attached).

I saw the conversation on IRC and I believe we should take the word of
the author if it's explicitly mentioned in the README.

>I think there is an issue here. The repository has no LICENSE file,
> and
> source code files have no license header. The only reference to
> AGPL3.0
> is in the README.md. I'm not sure this is sufficient.

Thanks,
Alex

Comments

Nicolas Goaziou Feb. 23, 2021, 7:07 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Thanks for the feedback, I updated the patch (attached).

Thank you.

> I saw the conversation on IRC and I believe we should take the word of
> the author if it's explicitly mentioned in the README.

Indeed. I applied your patch with a minor fix.

> +      (version (git-version "0.0.8-" revision commit))

"0.0.8-"  -> "0.0.8"

Regards,
diff mbox series

Patch

From 2434b06388935f50bb67c15fc7e1264f0e8bc9f9 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 23 Feb 2021 18:51:05 +0000
Subject: [PATCH] gnu: Add midicomp.

* gnu/packages/audio.scm (midicomp): New variable.
---
 gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 16e0eec418..372c056d16 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1223,6 +1223,37 @@  object library.")
 language and software synthesizer.")
     (license license:lgpl2.1+)))
 
+(define-public midicomp
+  ;; The latest tagged release is 9 years old and there have been
+  ;; unreleased fixes, so we take the last commit.
+  (let ((commit "70f76963cb0cdb3cbe03ec6e7246b1fb885d3c68")
+        (revision "1"))
+    (package
+      (name "midicomp")
+      (version (git-version "0.0.8-" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/markc/midicomp")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "12zh247c6v88ssy4l8v7yirh4bl2jcc1ch7f4gdry79a82kai1gf"))))
+     (build-system cmake-build-system)
+     (arguments
+      `(#:tests? #f))  ; no "check" target
+      (synopsis "Convert SMF MIDI files to and from plain text")
+      (description
+       "midicomp can manipulate SMF (Standard MIDI File) files.  It can both
+  read and write SMF files in 0 or format 1 and also read and write its own
+  plain text format.  This means a SMF file can be turned into easily
+  parseable text, edited with any text editor or filtered through any script
+  language, and recompiled back into a binary SMF file.")
+      (home-page "https://github.com/markc/midicomp")
+      (license license:agpl3))))
+
 (define-public clalsadrv
   (package
     (name "clalsadrv")
-- 
2.30.1