diff mbox series

[bug#70035,v2,2/8] gnu: openshadinglanguage: Update to 1.13.7.0.

Message ID 7185760428868307165e9786cfb12414e31b6396.1711639886.git.monego@posteo.net
State New
Headers show
Series Update and cleanup ASWF tools. | expand

Commit Message

Vinicius Monego March 28, 2024, 3:40 p.m. UTC
* gnu/packages/graphics.scm (openshadinglanguage): Update to 1.13.7.0.
[source]: Add patch.
[arguments]: Use G-Expressions. In #:configure-flags, pass the
"-DLLVM_BC_GENERATOR" option. Delete the add-ilmbase-include-path phase. Add
new tests to skip.
[native-inputs]: Use Clang 13 and LLVM 13.
[inputs]: Use OpenEXR 3 and Qt 6.

Change-Id: Ib3e7ed39c3eb170e3d24ccc74243ebff490e07ab
---
 gnu/packages/graphics.scm | 64 ++++++++++++++++++---------------------
 1 file changed, 29 insertions(+), 35 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index e10e157f61..20b783f01d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -707,7 +707,7 @@  (define-public mikktspace
 (define-public openshadinglanguage
   (package
     (name "openshadinglanguage")
-    (version "1.11.16.0")
+    (version "1.13.7.0")
     (source
      (origin
        (method git-fetch)
@@ -716,52 +716,46 @@  (define-public openshadinglanguage
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0x0lc163vl2b57l75bf5zxlr6vm2y1f1izlxdnrw3vsapv3r9k9g"))))
+        (base32 "0nb7kc7kh6k71wda3nzcwpiycx8lknl08y0c7ns6p7f4fab7kh1k"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags (list "-DUSE_PARTIO=OFF") ; TODO: not packaged
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'set-paths 'add-ilmbase-include-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; OpenEXR 2 propagates ilmbase, but its include files do not
-             ;; appear in the C_INCLUDE_PATH.
-             (let ((headers (string-append
-                             (assoc-ref inputs "ilmbase")
-                             "/include/OpenEXR")))
-               (setenv "C_INCLUDE_PATH"
-                       (string-append headers ":"
-                                      (or (getenv "C_INCLUDE_PATH") "")))
-               (setenv "CPLUS_INCLUDE_PATH"
-                       (string-append headers ":"
-                                      (or (getenv "CPLUS_INCLUDE_PATH") ""))))))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "ctest" "--exclude-regex"
-                       (string-join
-                        (list
-                         "osl-imageio"       ; OIIO not compiled with freetype
-                         "osl-imageio.opt"   ; OIIO not compiled with freetype
-                         "texture-udim"      ; file does not exist
-                         "texture-udim.opt"  ; file does not exist
-                         "example-deformer"  ; could not find OSLConfig
-                         "python-oslquery")  ; no module oslquery
-                        "|"))))))))
+     (list #:configure-flags
+           #~(list "-DUSE_PARTIO=OFF"   ; TODO: not packaged
+                   (string-append "-DLLVM_BC_GENERATOR="
+                                  #$(this-package-native-input "clang")
+                                  "/bin/clang++"))
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke
+                      "ctest" "--exclude-regex"
+                      (string-join
+                       (list
+                        "osl-imageio" ; file does not exist
+                        "osl-imageio.opt" ; file does not exist
+                        "osl-imageio.opt.rs_bitcode" ; file does not exist
+                        "texture-udim"    ; file does not exist
+                        "texture-udim.opt" ; file does not exist
+                        "texture-udim.opt.rs_bitcode" ; file does not exist
+                        "example-deformer" ; could not find OSLConfig
+                        "python-oslquery") ; no module oslquery
+                       "|"))))))))
     (native-inputs
      (list bison
-           clang-9
+           clang
            flex
-           llvm-9
+           llvm
            pybind11
            python-wrapper))
     (inputs
      (list boost
            imath
-           openexr-2
+           openexr
            openimageio
            pugixml
-           qtbase-5
+           qtbase
            zlib))
     (home-page "https://github.com/AcademySoftwareFoundation/OpenShadingLanguage")
     (synopsis "Shading language for production GI renderers")