diff mbox series

[bug#70035,v2,8/8] gnu: opensubdiv: Update to 3.6.0.

Message ID 02432389f666adf5e365ee4d0035b378dfacb493.1711639886.git.monego@posteo.net
State New
Headers show
Series Update and cleanup ASWF tools. | expand

Commit Message

Vinicius Monego March 28, 2024, 3:40 p.m. UTC
* gnu/packages/graphics.scm (opensubdiv): Update to 3.6.0.
[arguments]: Use G-Expressions. Delete the set-glew-location phase.

Change-Id: Ie37f70a5146e5072b362a4439d0669ea19ca2869
---
 gnu/packages/graphics.scm | 21 ++++++++-------------
 1 file changed, 8 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 5915ecc329..f7519c3abf 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1909,7 +1909,7 @@  (define-public fgallery
 (define-public opensubdiv
   (package
     (name "opensubdiv")
-    (version "3.4.0")
+    (version "3.6.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1919,20 +1919,15 @@  (define-public opensubdiv
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0cippg6aqc5dlya1cmh3908pwssrg52fwgyylnvz5343yrxmgk12"))))
+                "0h9scxiigijzlpv4r0s0nhxlndhv1cmarb2bqgmlwcln1jjvlb4n"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-before 'configure 'set-glew-location
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      (setenv "GLEW_LOCATION" (assoc-ref inputs "glew"))
-                      #t))
-                  (add-before 'check 'start-xorg-server
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      ;; The test suite requires a running X server.
-                      (system "Xvfb :1 &")
-                      (setenv "DISPLAY" ":1")
-                      #t)))))
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'start-xorg-server
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            ;; The test suite requires a running X server.
+                            (system "Xvfb :1 &")
+                            (setenv "DISPLAY" ":1"))))))
     (native-inputs
      (list xorg-server-for-tests))
     (inputs