diff mbox series

[bug#56717,v2,1/2] gnu: Add python-i3ipc.

Message ID 6fa4d8cb7d3d072fff1940fea71ddfa71bfc5d7f.1658572827.git.hako@ultrarare.space
State Accepted
Headers show
Series gnu: Add python-i3ipc and i3-autotiling. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain July 23, 2022, 10:31 a.m. UTC
* gnu/packages/python-xyz.scm (python-i3ipc): New variable.

Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

--
2.36.1

Comments

\( July 23, 2022, 10:48 a.m. UTC | #1
Almost LGTM :)

On Sat Jul 23, 2022 at 11:31 AM BST, Hilton Chain wrote:
> +    (synopsis "Python library for controlling i3wm and sway")
i3wm -> i3 and sway -> Sway maybe?

> +    (description "An improved Python library to control i3wm and sway.")
Maybe better as:

(description
 "This package provides a Python library for controlling the i3 and Sway
window managers.")

Also, have you run `guix lint python-i3ipc i3-autotiling`? Make sure to
do that and resolve any issues it raises :)

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 11f709f7b5..2115007a97 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -124,6 +124,7 @@ 
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
+;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30203,3 +30204,24 @@  (define-public python-bsdiff4
 binary diff utility.  It also provides two command-line tools, @code{bsdiff4}
 and @code{bspatch4}.")
     (license license:bsd-2)))
+
+(define-public python-i3ipc
+  (package
+    (name "python-i3ipc")
+    (version "2.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/altdesktop/i3ipc-python")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13bzs9dcv27czpnnbgz7a037lm8h991c8gk0qzzk5mq5yak24715"))))
+    (build-system python-build-system)
+    (arguments (list #:tests? #f)) ;a working X environment is needed to run the tests
+    (propagated-inputs (list python-xlib))
+    (home-page "https://github.com/altdesktop/i3ipc-python")
+    (synopsis "Python library for controlling i3wm and sway")
+    (description "An improved Python library to control i3wm and sway.")
+    (license license:bsd-3)))