diff mbox series

[bug#67919,51/55] gnu: Add rust-palette-0.7.

Message ID 6c3be7ac9067368dba90c0887e6db5581102c9d6.1703044085.git.jaeme@runbox.com
State New
Headers show
Series gnu: eza: Update to 0.17.0. | expand

Commit Message

Jaeme Sifat Dec. 20, 2023, 3:55 a.m. UTC
* gnu/packages/crates-graphics.scm (rust-palette-0.7): New variable.

Change-Id: Ia55d3b7788a04a410dacb7f53dcb2d2909f026c6
---
 gnu/packages/crates-graphics.scm | 46 ++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 82a76dc190..53e7ba3163 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1869,6 +1869,52 @@  (define-public rust-osmesa-sys-0.1
     (description "This package provides OSMesa library bindings for Rust.")
     (license license:cc0)))
 
+(define-public rust-palette-0.7
+  (package
+    (name "rust-palette")
+    (version "0.7.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "palette" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1p2inf23vsqy06w7vp7rcxmb9vk91asib534m9cafykn8x0z7qmj"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ; Can't find regression tests.
+       #:cargo-inputs
+       (("rust-approx" ,rust-approx-0.5)
+        ("rust-bytemuck" ,rust-bytemuck-1)
+        ("rust-fast-srgb8" ,rust-fast-srgb8-1)
+        ("rust-libm" ,rust-libm-0.2)
+        ("rust-palette-derive" ,rust-palette-derive-0.7)
+        ("rust-phf" ,rust-phf-0.11)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-wide" ,rust-wide-0.7))
+       #:cargo-development-inputs
+       (("rust-clap" ,rust-clap-3)
+        ("rust-criterion" ,rust-criterion-0.4)
+        ("rust-csv" ,rust-csv-1)
+        ("rust-enterpolation" ,rust-enterpolation-0.2)
+        ("rust-image" ,rust-image-0.23)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-rand-mt" ,rust-rand-mt-4)
+        ("rust-ron" ,rust-ron-0.8)
+        ("rust-scad" ,rust-scad-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/Ogeon/palette")
+    (synopsis
+     "Convert and manage colors with a focus on correctness, flexibility and
+ease of use.")
+    (description
+     "This package provides converting and managing colors in Rust with a
+focus on correctness, flexibility and ease of use.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-palette-derive-0.7
   (package
     (name "rust-palette-derive")