diff mbox series

[bug#67919,50/55] gnu: Add rust-fast-srgb8-1.

Message ID 3db523518f5d8a5f3d7b8c7198176a7c627dd0ef.1703044085.git.jaeme@runbox.com
State New
Headers show
Series gnu: eza: Update to 0.17.0. | expand

Commit Message

Jaeme Sifat Dec. 20, 2023, 3:55 a.m. UTC
* gnu/packages/crates-graphics.scm (rust-fast-srgb8-1): New variable.

Change-Id: If1ce13ad8c4f2a04b9f77a16063218d4540bd10e
---
 gnu/packages/crates-graphics.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 135cae9cc0..82a76dc190 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -871,6 +871,27 @@  (define-public rust-exr-1
     (description "Read and write OpenEXR files without any unsafe code")
     (license license:bsd-3)))
 
+(define-public rust-fast-srgb8-1
+  (package
+    (name "rust-fast-srgb8")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fast-srgb8" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "18g6xwwh4gnkyx1352hnvwagpv0n4y98yp2llm8vyvwxh487abnx"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/thomcc/fast-srgb8")
+    (synopsis
+     "Very fast conversions between linear float and 8-bit @code{sRGB} (with
+@code{no_std} support)")
+    (description
+     "This package provides very fast conversions between linear float and
+8-bit @code{sRGB} (with @code{no_std} support).")
+    (license (list license:expat license:asl2.0 license:cc0))))
+
 (define-public rust-gfx-0.18
   (package
     (name "rust-gfx")