diff mbox series

[bug#73520,1/2] gnu: xdg-desktop-portal-next: Fix configuration file search.

Message ID 6c0a8919ba4ccd7dea35b27b9f6ed9a22c57882a.1727461684.git.rodion.goritskov@gmail.com
State New
Headers show
Series Potential fix for the latest xdg-desktop-portal | expand

Commit Message

Rodion Goritskov Sept. 28, 2024, 7:41 a.m. UTC
* gnu/local.mk: Add patch.
* gnu/packages/freedesktop.scm (xdg-desktop-portal-next): Add patch.
* gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch: New file

Change-Id: Idd637f5613e7d1403fc3a0feeff53a7931e68fc6
---
 gnu/local.mk                                  |  1 +
 gnu/packages/freedesktop.scm                  |  5 ++--
 ...al-disable-configuration-search-exit.patch | 28 +++++++++++++++++++
 3 files changed, 32 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index c2027f9eeb..dc08ff2b82 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2311,6 +2311,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/wpa-supplicant-dbus-group-policy.patch		\
   %D%/packages/patches/x265-arm-flags.patch			\
   %D%/packages/patches/xdg-desktop-portal-disable-portal-tests.patch\
+  %D%/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch\
   %D%/packages/patches/xdg-desktop-portal-wlr-harcoded-length.patch\
   %D%/packages/patches/xen-docs-use-predictable-ordering.patch	\
   %D%/packages/patches/xen-remove-config.gz-timestamp.patch	\
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 23ed788689..73bd5c8a3d 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3086,8 +3086,9 @@  (define-public xdg-desktop-portal-next
        (sha256
         (base32
          "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
-       ;; Disable portal tests since they try to use fuse.
-       (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
+       (patches (search-patches
+                 "xdg-desktop-portal-disable-portal-tests.patch"
+                 "xdg-desktop-portal-disable-configuration-search-exit.patch"))))
     (build-system meson-build-system)
     (arguments
      (substitute-keyword-arguments (package-arguments xdg-desktop-portal)
diff --git a/gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch b/gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch
new file mode 100644
index 0000000000..4cb77de806
--- /dev/null
+++ b/gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch
@@ -0,0 +1,28 @@ 
+From 37003d1f99246c88cbe7cf2f83616642e0fdf3fb Mon Sep 17 00:00:00 2001
+From: Rodion Goritskov <rodion.goritskov@gmail.com>
+Date: Fri, 27 Sep 2024 00:44:07 +0400
+Subject: [PATCH] portal-impl: Check if there are any configuration files in XDG_DESKTOP_PORTAL_DIR before exiting configuration search
+
+---
+ src/portal-impl.c | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/src/portal-impl.c b/src/portal-impl.c
+index 8c1fd53..8708409 100644
+--- a/src/portal-impl.c
++++ b/src/portal-impl.c
+@@ -438,9 +438,8 @@ load_portal_configuration (gboolean opt_verbose)
+ 
+   if (portal_dir != NULL)
+     {
+-      load_config_directory (portal_dir, desktops, opt_verbose);
+-      /* All other config directories are ignored when this is set */
+-      return;
++      if (load_config_directory (portal_dir, desktops, opt_verbose))
++	return;
+     }
+ 
+   /* $XDG_CONFIG_HOME/xdg-desktop-portal/(DESKTOP-)portals.conf */
+-- 
+2.46.0
+